Simulation keeps crashing

I am setting up to do a 3D carve. But every time I run the simulation, about 1/3 to 1/2 way through Easel screen goes black for a few seconds, then comes back. Then the carve image disappears and I have a blank white screen. It stays like that for a couple minutes and then the whole thing crashes and I need to reload Easel.
I don’t want to start the actual carve for fear of it doing this while cutting a nice piece of wood.
Any ideas? I have made sure nothing else is running in the background on the computer.

I would contact Inventables’ support team and have the look at the file if the issue persists.

Here is the link explaining how to contact Inventables Support…

https://inventables.zendesk.com/hc/en-us/articles/360011686854-How-do-I-contact-support-at-Inventables-

{:0)

Brandon Parker

I’d suggest re running the simulation while having Task Manager (windows) or Activity Monitor (Mac) running to see the RAM usage. This may give you clues as to why the machine is crashing. If the file processing is too large then this will crash the machine, and is a warning of sorts that the carve will likely fail.

You can also troubleshoot by increasing the bit depth, size and decreasing the stopover as this will use less memory in generating the path (not that I’m suggesting cutting this way, but it will give you clues as to what’s happening).

Also take a look at Firefox, as you can customize settings such as network timeout etc (this has been an issue for some).

hope this helps.

1 Like

Ran the simulation with task manger open in the performance tab.
It does seem to be a memory issue. Both with the Ram and the GPU Memory.
As the simulation runs, both memories slowly tick up until its hits the 16 gig thats in my computer. Then the screen blacks out in Easel, the ram count drops. Then the simulation comes back and is continuing to run from where the screen dropped out. The RAM then starts counting up again to 16gig again. Once it hits 16 gig the second time is when Easel goes white screen. The computer sits like that for a minute or two before an Ooopps message appears saying something seems to have went wrong.
So my laptop running the carver wouldn’t run it for sure. Pretty sure it only has 8 gig.

1 Like

Ran a simulation with a carve I have already done successfully. The memory counted up to 7.8gig.
It was only a 2d carve. So I’m guessing had the carve been any bigger it may have crashed as well.

1 Like

Good to hear you’ve found out what’s causing the issues.

My experience is that the oops message is network timeout → can be solved with firefox if this is the only message. However if you’re hitting the 16gb limit / GPU limit then the carve will surely fail.

You’ll either:

  1. need to render on another computer and create g-code to run in Easel
    and/or
  2. increase tool size, depth and/or step over to reduce the number of tool paths being generated (not an optimal answer for many reasons)

For me, I had to abandon Easel for 3D carves because of this.

I had situations on a 16"x29" carve whether the roughing pass would work, and the finishing pass would fail. My only answer was to go and learn Fusion 360 (not an easy thing!), create the carve and the toolpaths in Fusion 360 and then export the various tool paths as separate g-code files to Easel.

1 Like