Single Line Fonts - only letters D and O are cut


I’m working an an acrylic faceplate that has engraved text labeling. I’m using a single line font in Inkscape, converting to paths, and successfully importing the file into Easel. Everything appears OK in the left window, but when cutting only the letters D and O are being cut, all other letters are ignored. Show toolpaths displays the same issue, only those two letters are being picked up.

I’ve tried adjusting the bit size, but no joy. Any ideas on what’s happening here?

Pic Added (w/exaggerated super-tiny bit size)

It doesn’t seem to like the open-ended paths for some reason. Can you post your .svg file?

or, which font are you using in Inkscape? Perhaps I can try to troubleshoot the problem that way.

Hi Mike, thanks for taking a look.

Here you go, the text saved as a plain SVG:

I’ve tried different fill/stroke settings (fill/no fill/diff stroke widths), saved as Inkscape SVG and Plain SVG, no luck.

Not sure if svg uploads are supported here, so here’s a download link:

Ok, it seems like there’s something janky about the way it converted the text into outlines. It looks like it tried to make closed shapes out of each letter rather than open paths, so it traced over the same path twice, closing the path at the ends. The really weird thing is that when I fixed that and re-imported the file to Easel, it crashed.

Can you tell me what font you used or maybe post it here so that I can try it from scratch?

The font is called Eng_UniversLine.

I downloaded the font, and played around with it in Illustrator. It’s doing the same thing for me as it did in the .svg you shared earlier. I’m honestly kind of stumped. When I just import the converted outlines into Easel, no matter what size I make them it won’t generate toolpaths for anything that’s an open shape. However, if I draw open shapes in Illustrator (like with the pen tool or line tool) and import them, the toolpaths render just fine. Also, I’m seeing the same ‘double-path’ thing happening when I convert to outlines, and when I get rid of the doubled path and import THOSE into Easel it crashes.

I did however try to import the svg into Makercam and it seems to work just fine, and it has the option of a “follow path” operation which is more appropriate for this kind of thing anyway. Check out

I’m sorry I couldn’t be of more help, I’m kind of at the end of my skillset here and still stumped.

Ah man, thanks for giving it a try, much appreciated. At least we’re seeing the same problem, so it’s probably not user error. :slight_smile:

Single line fonts + inkscape has given me grief since I first started playing with a plotter, it always takes some voodoo to get things exporting ok.

Thanks a bunch for the Makercam recommendation, been researching software alternatives, good to have a tried + tested tool to learn. Thanks again, Mike!