Inventables Community Forum

Skipping steps on X axis

Yesterday I tried to cut out a saw push stick, first time cutting something out since changing the x-axis, and found that the x was losing about a cm on the second trip round the shape. I used the recommended cut criteria in Easel for this. After tightening the v wheels (too tight I guess) there was a horrible sound and the motor spun but nothing moved. I redid the v wheels again more carefully but when I tried jogging I saw the x belt had come loose. I tightened it up and tried the cut again, it did two or three laps with a little bit of skipping I think, as the cut got slightly wider. Then it went way off track again. The belt had come loose again. After a third attempt I saw the belt was loose again, so I aborted the cut, but not in time to save my workpiece.
Although the belt looked fine to my untrained eyes I decided to change it today, as I bought a spare roll ages ago with the 1-piece axis. I also changed the sloppy original eccentric nut set up to the locktite plus nut version on the front two v wheels, (the back two have never given me any trouble) and that got rid of the loose upper v-wheel I mentioned in a prior post. Before putting the belt in, I noticed that when moving the gantry along the x axis it feels smoother than before, so after fitting the belt with heat shrink to catch the ends, I was all set to try on my last bit of plywood.
Sadly (for me) the second round of the cut started nearly a cm too short, so I am still loosing steps.
For Sunday I’ll check the belt is still tight, and re-adjust the x axis pot on the g-shield. Is there anything else I should do?

Today I tried adjusting the x axis pot in the g-shield as per Robert’s video. Once done I did an 8 minute aircut back and forth in the x direction only and when finished and returned home the bit was 2mm to the left of where I started.

My v-ref from the pots are X=1.49V, Y 2.3V (is this too high?) and Z 1.22V. I ony fiddled with the X axis today.

Also, my steppers have a label that says KL23H251-28-4A, does this mean they are Nema 23s?

Any help greatly appreciated as my teaching business has pretty much gone bust and am hoping to produce a few saleable items while we are under restricted movement orders here.

Monday update:
The motors are Nema 23s (Thanks to customer service email).
I tightened one of the Y belts a little, I don’t have a digital fishing scale but they feel/sound similar.
I adjusted the Y pot. I ran a big square 50 x 50 cm cut at 4000 mm /min for about 5 minutes and checked if it homed to the right spot, the y coordinate was good but the x was still about 1 mm too far left. I also noticed the z was about 1 cm higher than when it started, so I redid the z pot as well in the g-shield.
After that I checked the voltages, x is same as yesterday 1.49V, y is now much less, 1.72 and z is now 1.79.
I then ran a big circle air cut 50 cm diameter at 4000 mm/min for 11 rounds and checked my home spot. This time it was about 1/2 mm to the left on the X direction, y direction looked good, but the z was still about 1.3 mm higher.
So things are better, but still not as exact as they should be. I ran at that speed because in Robert’s video I think he ran at 200 inches/min, I wasn’t that confident of my machine assembly skills.

Still keen to get any suggestions as what else may be wrong. :thinking:

I believe it has been said the the original gshield did not have enough power to drive NEMA 23 steppers.
That is why the X Controller was released.

The drivers will not be able to bring out the full potensial of the Nema23’s for sure, their current rating is less than nominal for those steppers.

I think I solved this one, is it that after finishing a carve when the cutter returns to work zero it doesn’t actually return, but stays a few mm high to avoid the spinning bit touching whatever you zeroed off?

Thanks for your comments Mark & Haldor, I’ll have to just plug on with the original controller for the moment. At least I can now do some cutting. :smiley:

Correct :slight_smile:
After a carve the machine will return to X0, Y0 and Z0-SafetyHeight (default 3.8mm)