(SOLVED) Arduino won't connect to PC (nor MAC)

Hi dear people,

I’m trying to connect the arduino to the PC and it won’t connect.
I tried with mac but this is the message I get:

Because a USB device was drawing too much power from your computer, one or more of your USB devices have been disabled.
To prevent damaging your computer, the USB device drawing too much power has been disabled. Other devices may have also been disabled…

Thank you for your help!

Is that the only USB device you have plugged in to your Mac when you tried it?

Yes, it was the only device at the moment.

hmmm… ok, I won’t be able to help much on the Windows side of things, but would you mind posting a few more details about your computers? Operating System versions, ram… Is the Mac an older machine?

This sounds cable / computer related. I found this thread: https://discussions.apple.com/thread/4752308?tstart=0 in a google search.

But also found this one: http://forum.arduino.cc/index.php?topic=5828.0 in case it is Uno related.

Buy one of this with external power adapter, juice up you USB power.

Windows 8.1 for PC and MAC book pro from 2009.

Problem solved, I connected gshield wrong to the arduino board. That made the problem. Now it’s working as it should.

1 Like

I am also having the same issue and I am not quite sure how you mean you connected the gshield to the arduino incorrectly. Could you please maybe post a pic? I have also tried using a powered USB splitter and that isn’t playing cricket.