SOLVED - Can anybody give me some advice?

I’m having a hard time with the xcarve, because I can’t find the proper settings to carve, first, I changed, eccentric nuts, I changed the X axis (one piece rail instead 2 pieces), I adjusted belts, I changed crimp contacts, adjusted wires, I cleaned dust everywhere, etc. But, I’m losing steps in the Y axis, no matter what I do, it always happens, I reduced working speeds trying not being so agresive with the spindle rates, etc. finally I could get not errors, working with a V-bit, also I managed the potentiometers and I could get not losing steps, working with a V-bit (11 mm diámeter), but at the time I changed bit for a flat and straight one (6 mm diámeter), machine gradually is losing precision (steps in the Y axis), I arised the current for Y axis until 2,45 V. and for X axis 1.675V, i added another fan to cool the system, etc. May be setings are not right for the wood I’m working, anything, please any advice will be highly appreciated. these are my settings for the pinewood I’m working
DEPTH/PASS 0.01181 in

Is the same problem, why?

May be I can get some other people experiencing same problem. I tried everything was suggested, but no improving

May be, is my fault, thanks Mr Phil

Trust me @MiguelPrada I’ve been where you’re at. I’m still having trouble. @PhilJohnson has helped me more than I could ever repay him. More than likely it’s your steps.

I get a 30 degree engraving bit and put a put a ruler down and send it 300mm and see where it lands. That helped my issues tremendously. I’m still having issues, so I’m upgrading to a screw drive system by @PhantommFangs to further my progress and decrease issues. I’ll let you know because this will eliminate belts and not worrying about always checking tension


The screws will completely eliminate step issues. However they do need a first time tuning then checked out once in a while.
Mine has been holding tight since my last tuning. But I have not done any carves recently since I have been so busy with the kits.


I’m thinking the same, I reviewed losing wires 3 times, I even bought crimping tool and connections and changed them, I’ve managed potentiometers up and down “milimetrically”, and at the time it looks is solved, error is back, and You know X axis motor is perfect!, I really thank everybody for their help and comments, now I’m thinking I’m doing it wrong, I believe settings feed and speed rates are not the right, but I believe taking more than 3 hr to cut a 28cm x 57cm, 22mm thickness, round perimeter, it means I’m not being agresive with the settings, anyway, I’m planning on buying another router, with technical service available in my country. Mr Phantomm let me know about screws, thanks again.

You can perhaps try to reduce your acceleration settings in GRBL, try to reduce it by 50% and test again?

1 Like

Robert as U said, Painfully I’m getting to that conclusión, bits are the key, and today I’m gonna prove a new set of bits I bought, let’s see, Thanks

Here is an idea that I haven’t seen floated yet. If your machine is brand new then it is possible that the Delrin nut that the Z axis lead screw passes through needs to be worn in. On my machine it was so tight in the beginning that it was very difficult to turn the lead screw by hand. If this happens then the Z axis will generally move downward without much problem given that gravity and the added weight of the Dewalt is helping it along. However when it is given the command to move upward the motor just doesn’t have the power to overcome the weight of everything combined with the friction of the Z axis nut. When the machine is cold it works ok but as your carving progresses, the repetitive up and down movement begins to generate a little heat in the nut and lead screw and things tighten up. The Z axis motor also begins to heat up (especially if you have turned up the power to it) and when it gets hot it can loose power until it gets to the point that when the Z axis is supposed to move up .2 inches it actually looses steps and only moves .019 inches. Then over time those missed steps moving upwards compound themselves and before you know it your are carving your waste board and then you break a bit.

What I did to resolve the problem was to remove the lead screw and nut. Mount the lead screw in a drill and the nut in a vice, then run it back and forth at a reasonably high speed. This caused the nut to loosen up just a bit. Don’t over do it though or you will end up with a loos nut that will have slop or backlash in it. Once I did that I never lost any steps again.

Inventables Tech support is where I got the tip to do this.

Hope this helps,

Charley Thomas
Triquetra CNC


Charley I just found one very tricky thing was affecting the machine, the prisoner screws at the Y motor pulley, I guess it is the problem, they were lose, but It was something I couldn’t figured it out!, just now, when I was re-tightening belts, hard, so I could make a test, and then I could see pulley was losen, thanks for helping

Yes, good!, is better, I can see them if they are tight or not

1 Like

Glad you found the problem… Now get to creating something you’ll be proud of!!

1 Like

this is my instagram page, I’d like You please to vist @mokananet and also my webpage, thanks