[Solved] Cannot Home through GRBL

I purchased an X-Carve and V-Carve Software for the Designs. After many searches I found I had to get a GRBL GCode Sender, I tried GCode Panel, Universal GCode Sender and others. I flashed the Arduino Board and did other steps to set up. I save the Paths (GCode) and connect. When I run the G Code Controller, I cannot figure out how to move to the position I want x, y, z and set so that is my home position. When I run code everything goes haywire. I don’t want to use limit switches. I’m totally new to this so I need simple, step by step instructions. Please help. This has become very discouraging.

Simply, on UGS Going to machine control, click $X if it’s on alarm state, then click $H. It will home zero your machine.

Just to make sure I understand. There is a difference between homing switches and limit switches. Do you have any switches hooked up on your machine?

Miss reading. If you don’t want to use home switches, go machine control, enable use keyboard bullet, jog it to your material front left corner, click Reset zero - reset X - reset Y. After that you can jog again to surface of your material, lower down your bit .01 in or .1 mm one click at a time, put piece of paper underneath the bit and move continuously until bit touching and paper doesn’t move anymore. That’s your Z zero. You can click on reset Z, you’re good to go. Browse your Gcode, download it then hit the start button. Sit back and enjoy the party.

1 Like

With MatthewPaden’s help and the posts here everything is figured out and working on my X-Carve now. Thanks for the help. Also see: https://discuss.inventables.com/t/x-carve-homing-and-g-code-sender/13137/3



I tried your link above and go the following error;
Sorry, you don’t have access to that topic!