[SOLVED] Easel doesn't recognize the driver

I have been using my XC for awhile now and suddenly today it won’t connect to my laptop. I tried using the “set up your machine” tab and it took me to the page that welcomes you when you first get your XC put together, saying that I have to download the Easel Driver. I reinstalled the driver (both 0.2.7 & 0.3.1) but it doesn’t seem to recognize that they are installed. I rebooted the laptop a number of times but am not getting anywhere. Can anyone tell me what to try next?
BTW, when I plug the cable into the X-Controller there is a small audible sound from one of the stepper motors so there is definitely a connection there, of some kind.

I’ve never installed UGS and don’t know what the Arduino is. Part of the X-Controller?

I uninstalled Easel Local and reinstalled; still nothing. When I plug the USB cable into the X-Controller the CARVE button does not turn green. I have tried a few different cables to see if that could be the problem but still no joy. Is there a way to reset the X-Controller? Not sure what else to try and this is getting very frustrating.

Yes, many times. I just reflashed the grbl & Arduino - I had to figure out how so that took some time. I reinstalled Easel Local again and the carve button still won’t turn green. The grbl upload worked so obviously the computer is communicating with the XC. I’m going to reboot again right now just for the heck of it.

I only have one port on this laptop and the device manager shows it open up every time I plug the cable into the X-Controller. If it knows the XC is there I don’t understand why the carve button stays blue. I just reinstalled the Easel Local AGAIN and it still isn’t working. I think I’m too late to call the support office at Inventables but may have to try that tomorrow. Another day wasted!! Thanks for the help, Phil.

I’ll give that a try, Phil. Thanks!!

1 Like

I know, Robert, and I’ve tried 4 cables. I don’t think that’s it but thank you for the input.

Well, I know that the computer is the problem, not the XC. I used a second laptop and it worked just fine. Now, I guess it’s time to call the Customer Success people! I haven’t been able to make any progress on my own. Thanks to everyone for trying to help. I will update what the problem is once I get it figured out.

And the saga continues! Paul from Customer Success found that it will work with Chrome and I have been using Internet Explorer. Why it would work for weeks and then stop yesterday has yet to be figured out. I was not using Chrome because for some reason I cannot get the preview to work; Paul could not get it working either and said he will get back to me about it. At least I can use it now: I hope!! I also hope Paul can figure out why IE does not work. I’m just more accustomed to using it.

If you have automatic updates turned on for Microsoft you could have gotten an update that messed things up.

After spending time with Paul from Customer Success he managed to figure out that the problem was with Microsoft Edge. THANK YOU PAUL!! With Google Chrome I am able to use Easel but for some reason (even Paul couldn’t figure this out) I can’t see the preview. With Firefox I am able to use Easel and CAN see the preview. So I guess I will be a Firefox user for the foreseeable future. At least I’m back on the learning curve!!! :smiley:
Thanks again to those who gave their friendly advice.

Do you have webGL enabled?

I’m using Windows 10 and it doesn’t work. Paul Stolz was helping me yesterday and could not figure it out, either.

I think XP is too early to be supported.

Win 10 should work. Paul Stolz might have to escalate it.

Don’t worry

I was forced to update the driver, and now easel will not work
I have tried everything from reinstalling, uninstalling, bought new cables, rebooting pc, and it no longer works. Everything was perfect until the driver update

Oh well

Which Browser are you using? Microsoft Edge? Chrome? Firefox? Or have you tried more than one?

this is happening to me now, did you resolve the problem?

I was having the same problem, and I was using chrome. (This is all on my Mac.) I switched to safari and was able to communicate with the x-carve.