[SOLVED] Easel will not see X-Controller in Chrome this morning

Wanted to see if anyone else is having trouble with Easel seeing the X-Carve this morning?

Last time I did carve it fired up great no issues. Today i booted the computer there as a windows 10 update (did them) restarted and Easel will not see the X-Controller now. In Device Manager I see Com 3 when I turn on the controller, and if I go into Devices & Printers I see the X-Controller and it says “working correctly”, but when I go to Configure Machine it will not see it. In troubleshooting, I set the COM to 3 and it just spins forever.

Any suggestions or help would be appreciated.


I had the same problem one time and it was my e stop button not fully depressed . Worth a try. Or maybe another program like ugs open?

Im having connection issues. I can start carves then it will stop mid carve and ask me how everything turned out. Some projects I have to do 2-4 times then I have to start over. I have to turn the controller off rehome and start all over . This started last night.

Sounds like USB drop-out. Either intentionally by your PC or by flaw as in bad USB port, cable or RF-noise.

Here is the Error showing on the USB COM3 Events: Device FTDIBUS\VID_0403+PID_6001+XCONTROLLEROASGI\0000 requires further installation.

Any ideas would be much appreciated.

These are my Device Manager Screens

Had trouble getting connected to chrome today. I’m using windows vista today. Took forever but finally connected.

Mine was not connecting either then I finally changed the usb cable and haven’t had any problems with it . Good luck

Thanks @PhilJohnson, I’ll give it another show tithe it set to 115,200 but did try that yesterday which did not seem to have an impact. Let me try it again this morning.

As always I appreciate your help!!


1 Like


I just tried changing the but rate and still no connection. I also tried reinstalling the drivers again after the change and a reboot… still nada. :frowning:

Is there possibly something in the Advance settings I have wrong?

In Machine Inspector I see something is opening the port then closing it over and over.

Thank you Phil! Where is the .bat file located? Any idea what directory?

Hey Phil,

I did exactly what you said and created a .txt file, pasted the 3 lines in it, then renamed it a .bat file on my desktop. I execute the file as instructed after closing Chrome etc. it opens a CMD window and closes Easel then restarts it. I then hit any key to proceed and Unplug the USB (I hear the PC acknowledge that a USB has been removed) plug it back in (again PC chimes confirming) then re-launch Chrome… and run Easel. Still getting the “Opening COM3… Access Denied” --> Port Open over and over.

Any other tricks that come to your knowledgeable gray matter?


LOL… Not sure but at this point I’m willing to try anything! I’ve got 4 cutting board blanks for Christmas Gifts and at this point it looks like I’m heading to the store tonight to buy gifts instead. :frowning:

Yes I tried rebooting both the X-Controller and the Computer. I do not have anything else open, I’ve never tried UGS.

I can certainly download it and give it a try, is there something special I should try/do to diagnose my issue in UGS?


Don’t forget to download and install Java if you don’t have it. UGCS uses Java.


Well John at Inventables gave me a call and he figured it out. Apparently, and neither he nor I have ANY idea how this could have happened… but apparently my X-Controller lost its Firmware completely.

He went to the Andrino website and downloaded/reflashed my Firmware and Bingo… it was back online. Again he said he had never seen that before so it was an odd fluke… good news is I’m back to carving (well not tonight but tomorrow… back at it.)

Thank you so much for your help @PhilJohnson and @JohnHayes You both ROCK!!!

Merry Christmas!

1 Like