SOLVED: Fusion 360 Post Processing Failure - Tool Orientation

I am using Fusion 360 to generate tool paths and hopefully G-code to import directly into Easel for cutting on my new 1m X-Carve. Today I downloaded the Easel Post Process for Fusion 360 and pointed Fusion to that file for PP actions. For debugging purposes I’m trying to do a single simple 2D contour. Unfortunately, each time I try to post the G-code there is a failure. Here is a sample of the NC file output:

G90G94
G17
G21

(TOOL/MILL,1.473,0,4.762,0)
(STOCK/BLOCK,609.6,3.175,304.8,0, 0, 0)
M9
T1M6
S8000M3
G54
!Error: Failed to post data. See log for details.

Trying to import this into Easel (even though it fails) gives no carving data. Anyone having similar issues or have a solution? THANKS!

A few questions:

  1. Are you running the Simulation process in Fusion? If so, what does the path look like?
  2. Have you looked at the log file in Fusion?

Looking at the gcode in your post, I suspect that there is no tool path in fusion for the post processor to process. Running Simulation will give you a popup error window in Fusion.

Never used Fusion 360 but if I remember correctly, I’ve read that the T1M6 line should be removed from the gcode before importing - either from the PP or from the resulting gcode.

You have to turn on the option in Fusion to open the generated code in the editor in order to see the log. Once you do that take a look at the log and post what’s there.

The simulation works and there is a proper tool path generated. No luck finding a log file yet.

Thanks StevePrior, do you know where that option is in Fusion? No luck finding it yet.

I don’t have Fusion in front of me, but when you actually do the post processing you bring up a dialog box, the option to open the generated gcode in the editor is a checkbox in that dialog.

I see that dialog but checking it doesn’t do anything. I’m starting to wonder if I have a bad install or something with permissions is blocking some functionality of Fusion. I’ve tried multiple other post processing files and all return the same error of inability to post.

If you go to the Post Process dialog and click on the “Open Config” button on the Post Configuration line, does an editor pop up (might need installing the first time)? I’m wondering if the editor that gets used when you select “Open NC file in editor” hasn’t been installed yet and maybe won’t be installed because of that checkbox, but will with the other Open Config button.

Some success but not out of the woods yet. I managed to get the NC log file to open in what appears to be the editor after telling it to post. Here is what is output. It appears that the major error is in tool orientation definition. I’ve assumed that setting up the work such that the Z-axis is the tool axis (up and down) is correct with the X-axis being left and right, and the Y-axis being front to back (relative to the machine). Here is the output as displayed in the Brackets editor.

Information: Configuration: Easel
Information: Vendor: Inventables, Inc.
Information: Posting intermediate data to ‘C:\Users\a2.nc’
Information: Total number of warnings: 1
Error: Failed to post process. See below for details.

Code page changed to ‘1252 (ANSI - Latin I)’
Start time: Monday, January 30, 2017 7:20:44 PM
Code page changed to ‘20127 (US-ASCII)’
Post processor engine: 4.2.1 41279
Configuration path: C:\Users\f360-easel.cps
Include paths: C:\Users\Posts
Configuration modification date: Saturday, January 28, 2017 3:37:12 PM
Output path: C:\Users\a2.nc
Checksum of intermediate NC data: c1a2f0dfefd7840229239ae5e44eddae
Checksum of configuration: f722a5905055e04329ac0fa4e8e55f75
Vendor url: https://inventables.com
Legal: Copyright © 2012-2015 by Autodesk, Inc.
Generated by: Fusion 360 CAM 2.0.2681

Warning: Work offset has not been specified. Using G54 as WCS.
Error: Tool orientation is not supported.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Error: Failed to invoke function ‘onSection’.
Error: Failed to invoke ‘onSection’ in the post configuration.
Error: Failed to execute configuration.
Stop time: Monday, January 30, 2017 7:20:44 PM
Post processing failed.

I’d have to look more tonight, but it looks like it’s not the actual tool orientation that it’s complaining about, it’s that this post processor doesn’t support the specification of the tool orientation even being there. Did you change any settings regarding tool orientation, I don’t remember if there’s a checkbox related to that in the post processing dialog box.

1 Like

BINGO! Thanks Steve for the interpretation of the error. I went back and reoriented the sketches to be on the front plane instead of the top plane (tool defaults to align with Z-axis which is perpendicular to the front plane in Fusion). I then turned off the redefining of the tool orientation and it posts now!

2 Likes

Good! You could have also changed the definition of the axis in the CAM setup instead of reorienting the model.

The intent of a “setup” in the CAM workspace of Fusion is to represent the placing of a piece of material in a machine in a certain way to perform operations on it. This is modeling real life, so you should have exactly the same number of setups defined as times you’d fasten the material in a machine:

  • putting the blank in the machine (that’s a setup)
  • taking the blank out and flipping it over (that’s a setup)
  • changing bits without moving the blank (that’s NOT a new setup)
  • moving the blank to a new machine (that’s a setup)