[Solved] I'm stuck here

Just finished setting my Xcarve up this afternoon, and went to set up the machine and this screen came up.

other probably relevant information:

I’m using a Mac if that makes any difference. until I opened this window, this was the only tab open in chrome for about a half hour. I assumed the computer was doing something but it hasn’t changed at all.

I restarted my computer with the USB unplugged and waited until this screen came up to try again.

Did you download the Arduino driver/software?

it insists that I don’t need to, there hasn’t even been an option to do so anywhere.

Edit: I just downloaded the Arduino controller, from arduino.cc and had it test run the blink program, and it made the LEDs on my Arduino blink, indicating that the Arduino is communicating just fine with my computer, but the Gshield seems to be uncooperative.

Edit 2- the arduino.cc program lists USB as an option under the Port menu when the Gsheild is not connected but doesn’t list USB as an option when the Gsheild is connected. I’m wondering if I burned something when I was soldering the limit switch plug in thing

Will, I got some good news and some bad news.

I’ll start with the good news. It sounds like you got the Arduino drivers installed. Yea!!

The bad news is by installing the blink program you wiped out the GRBL software that came on it that you need to use to run the x-carve. You will have to reload the GRBL software on it.

Hopefully this post will help you out.

If not, we will try something else.

That whole post seems way above my head and I can’t figure out a way to just download what I assume is the code from the link you provided and upload it to the Arduino. It might be best to assume I know almost nothing about programming.

I have resolved to simply call customer support in the morning and I will post whatever solution they have for anyone else out there with only moderate technical savvy.

I do appreciate the attempts at help though.

For anyone else who’s made the same mistakes I have to this point follow this link.


According to Jon (John maybe?) - The team at Inventables may not have correctly flashed the Arduino’s sent out recently (I received mine from UPS on Monday, July 27th, 2015 - for reference). The fix is to wipe the Arduino and re-load the software - Jon suggested doing it with the Gshield disconnected from the Arduino. I will report back how this works.

I had multiple issues at the beginning, one of them was corrupted hex file on Arduino.
Can you please follow this link. You can understand how to flash Arduino and upload proper hex file.

Everything worked great - now I’m onto my next troubleshooting issue.