Solved - intermittent connection, stopped carves and easel connection

First off, Grifin and team, you’re awesome. You provided excellent support and I appreciate it very much.

So for the rest of you, I have some food for thought on a couple of issues recently that i’ve since worked out. It appeared that I had a couple of issues going on, but not necessarily one solution on the forum that addressed them all. So if this is redundant; please let me know.

Here’s my setup:

  • 1000mm x 1000mm x-carve
  • acme screw
  • DeWalt 611
  • X-controller
  • Microsoft Surface Book
  • Chrome

Problem 1:

  • after putting my x-carve in a custom enclosure I built, carves would stop mid-project and not connect with easel

Solution 1:

  • i removed my wires from a mesh sleeve that bundled them nice and tidy and was actually causing interferance

Solution 1.2:

  • I still seemed to have intermittent failures so, I added a powered USB hub and used a USB type 2 cable (i think) which ran straight from the hub into the x-controller, and bypassed the connection which was provided. Lastly, I made sure that all elements that needed plugged in (DeWalt, X-controller, computer, and shop vac) were not running off the same circuit. I somehow believe that the draw might have had something to do with it.

So - if it helps one person, i’d be happy. Hopefully you haven’t taken the time to read all of this to be annoyed - but again; my issues weren’t the typical ones listed in one single post which made troubleshooting a bit more difficult for a newb like me.

Good luck folks