[Solved]Lost connection from USB to Arduino

I am stumped. Before I took everything apart and rebuilt with the X-Carve upgrade my laptop had no problem opening comm 3 to talk to the Arduino/Grbl. After getting everything all put back together with the same Arduino/Grbl and the new power supply nothing can talk to the Arduino. Not Easel or UGS.

I have tried loading the Arduino drivers again, reloaded the Arduino IDE, reloaded the Easel Local code. Nothing has helped.

The power supply fan is running, the power light on the Arduino is lit up, the USB cable is plugged in.

I have not upgraded the version of Grbl from what I had with the SO2.

I am running Windows 8.1 and when I look at the device settings the Arduino driver has the little warning triangle with an exclamation point, so it appears that Windows is thinking it is a driver problem, But I have reloaded the driver several times with no noticeable change.

Maybe I am not loading the correct driver, Can someone please point me to the correct driver and I will try it.

Thanks for any help you can offer, I am very anxious to get past this problem so I can find the next one.

Have you tried a different USB port? If it’s still showing up in device manager with a warning symbol, you might try right-clicking and removing the device, unplug it, uninstall and re-install the Arduino software.

Hope something works out for you :slight_smile:

Hi Allen,
Not sure how helpful this is but I am also on 8.1 and see the exclamation mark you mentioned in device manager. Mine works fine.
When connecting to UGCS and Arduino software I see it adds the port that I am on after I plug it into the USB port.
Hope that helps.

Well, I have tried everything I can think of.
I have uninstalled all the arduino software and reinstalled it, no joy.
I have tried all the USB ports on the laptop, no joy.
I have tried the old arduino drivers, no joy.
I even configured Windows 8.1 to allow unsigned drivers, no joy.
I tried manually loading the arduino drivers, no joy.

So I am very frustrated and confused. I am beginning to think the problem lies in the Arduino board, but it was working when I last tuned the machine off to install the X-Carve upgrades.

The Arduino board should be drawing its power from the USB port so it is not even powered by the new power supply.

Any new ideas will be appreciated.

A few stabs in the dark. Try fiddling with the G-Shield/Arduino union to be sure its seated properly. Double check pin connections into G-Shield.
And one last thing that might just be it. Go to the x carve assembly instructions, at the last step there is a “get carving” button that lauches you into a new configuration within easel, where it “re-finds” everything and makes sure you have the right drivers. I have seen a lot of problems resolved by going specifically through that path. Good luck!

And by the way, try the last idea first. I know your not building from scratch but try it anyways.

You can also revisit this link that will take you straight to the same place…


1 Like

One final guess… Remove the Arduino completely and connect it, without the shield or anything else involved. I would open the Arduino software, look for the ports available, then plug in the Arduino with the USB cable, and then look at the Arduino software to see if a new port has been added. As long as it does then you are good to go.
I also ran into one Arduino that would not take power from the USB. As long as I added external power to the power jack on the Arduino it worked fine.
Good luck Allen, I hope something works for you.

1 Like

ive seen similar happen, turns out the grbl shield wasnt correctly seated to the arduino

Thanks every one! It looks like the problem is that the Grbl shield has a bad connection with the arduino (I wish I had prizes for each person that correctly diagnosed the problem).

1 Like

Just really glad you got it figured out! That had to drive you crazy!

no worries buddy, here to help :slight_smile:

As expected fixing that has taken me to the next two problems.

  1. My Z axis NEMA 17 motor is acting as if it has no torque, it can not turn the ACME rod. If I remove the drive belt then it turns correctly on command. When the belt is connected, it is very easy and smooth to turn by hand, I have fully loosened the eccentric nuts on the z carriage (so loose there is some play).

With my old SO2 I was having problems with the Z axis, somehow the threaded rod (not an ACME) got bent and it was very hard for this same motor to move the z-axis. Is loss of torque a failure mode for a NEMA 17 stepper motor? I am thinking I may of damaged the motor by making it work to hard with the old setup.

NEMA 17’s are pretty cheap so I am thinking I should just order a new one.

  1. The x-axis controller on the Grbl seems to be non functional, If I try to jog the x-axis from Easel nothing happens, I have moved the X motor to the Z controller on the Grbl and it responds correctly so I am pretty sure the wiring is correct to the motor, I also noticed that the X-axis LED on the Grbl does not light up when I attempt to jog the X-axis. The Y and Z LED’s light when I jog them.

So it seems to me that I may have broken the Grbl board when the pins where not correctly seated on the arduino.

But other than that everything is working great :frowning:

I just ordered a new G Shield from Inventables, I wish there was way to pay for faster shipping.

I had a problem with my Z-axis stalling. Just had to bump up the current a bit on the gshield until the replacement threaded rod and nut are installed.

How did you increase the current?

There is a current-set pot for each axis. Mine were all set at 50%, so, I bumped Z a tad.

I just tried that and the Z motor is still not moving at all.

Can you move the affected axes by hand when the power is on?

Yes, it moves pretty easy with power on. That does not seem like a good sign.