[Solved] Machine setup woes....click, click, nothing - GRBL needed to be flashed

So, I have gotten to the machine setup portion using Easel. I have properly stacked my gshield and arduino ( after many tries ) When I type in the com port. I get a slight jerk from the steppers, and thats it. I have read and read about similar problems but dont see or understand what to do next. I have three solid green lights. wires are correct. anti virus is off. I can not connect using ugs either. Im highly frustrated at this point. Ive burned up my extra usb ports with a power surge. So i cant try any other ports. Im clearly in over my head. I realize there are several similar topics. I feel my case is slightly different, having green lights, and some noise from steppers.

update connected with ugs. but couldnt move or do anything. Where do I go from here?

do you use a desktop or laptop? if you use a laptop it’s possible that the usb port doesn’t has enough power. This can be fixed with a usb hub with it’s own power source.

Interesting, yes. It is a laptop.

Its still just stalling and giving circle of infinite death in easel though… I cant get past the enter com port portion. Same issue??

maybe you can try to hook it up a desktop pc of a different laptop?

on my laptop it works fine. But when i start up, i need to turn on the x-carve first and then the laptop, otherwise it doesn’t connect.

Just as an information gathering question: do you have the Arduino IDE drivers installed?

Also, are you using chrome?

When you connect with UGS is the system in the “Alarm” state. If so you either have to Home your machine ($H) or cancel the alarm ($X). Then you should be able to jog your machine.

Just be careful if you cancel the alarm as the grbl software doesn’t know where your spindle is located in machine space.

I cant seem to update the driver. But i think its good. Here are ss of the properties. And I tried in chrome and IE

Solved. Grbl needed flashed. Easy fix. Thanks John!! Im up and running

1 Like