[Solved] OSX Connect with machine

I’ve searched through everything I can find and can’t get the solution I need. I recently bought a new to me older Mac to run the x-carve. I was running a late 2006 with Snow Leopard but it was so slow I upgraded a bit. This machine was running the newest El Capitan and couldn’t get it to connect to the x-carve. My old Mac had no problems, was just slow. I carved probably 20 items with zero issues except user error.

Today after some reading, I tried to get into recovery mode and couldn’t. I ended up reloading El Capitan and finally got into recovery mode. I did the csrutil enable --without kext and rebooted. Now when I turn on the power supply to the xc and plug in the usb, I hear the motors twitch like before. However, in machine setup, I still can’t get it to see the xc. When I look through the hardware list, it shows the USB ports, but just spins the cursor and won’t show anything.

Any help would be greatly appreciated. I’m about ready to hook up the old machine and just use it. I’m not ready to move to Windows. Ha.


Hi Jason

Is the Mac 32 bit or 64 bit?

Hey Zach. It is a 64 bit according to the chart. It is an Intel Core 2 Duo.

I hooked my old Mac back up a did a test carve and everything worked as it should. So it is definitely an issue with my new Mac as I suspected.


The chart can be wrong. I have a Mac that I can’t get to work and the chart says it is 64 but when I go into the about this Mac menu it says 32.

Click the apple and try to find what it says.

Thanks for helping me Zach. I struggle with some of this stuff. I can’t find where it says in About this Mac. Everything I read says click more info, but that doesn’t show up on my machine any where on the tabs in the About this Mac. I clicked option and the apple and system info to find the Intel info I stated earlier. Anywhere else I can find which bit I have?

Click the apple
Click about this Mac
Click more info
The copy the name of the processor and paste it into google. The first result click and it should say if it is 32 or 64 bit

The Google search of 2.4 ghz Intel core 2 duo said 64 bit and I also went into terminal, typed uname -a and it said “RELEASE_X86_64 x86_64” which according to Google is the 64 bit as well.


Also in system info, after unplugging the usb and using the machine away from x-carve, the usb tree info will show up. It never will show anything when I have my machine hooked up in this usb tree tab.

64 bit is good that’s what you want.

Do you mean if you plug in a USB mouse it doesn’t work either?

Sorry. No the usb mouse and keyboard work, but no info will ever show up on the usb tree in the system info when my x-carve is hooked up though the USB cable.

Not really sure that this is relevant, just thought I’d throw that out there in case it meant something.

Did you install any drivers on that computer? Specifically the FTDI USB drivers even if it was for something else?

I haven’t installed any drivers, but I did buy it used. I’m not seeing anything in the software tab of system information. A quick Google search said it would show up under system information/software/installations.

It’s possible the last person installed the FTDI driver which would make Easel Local not work.

Search FTDIUSBSerialDriver in spotlight and see if anything comes up.

Nothing shows up in the spotlight search.

What about just searching FTDI

No results for just FTDI either.

Send a message into our support team.


They might have seen this before and know how to fix it. If not I know one of our software engineers was working on El Capitan when it first came out and has more knowledge about it than me.

You might also check if you are on the latest version because I believe Apple pushed out some fixes to issues in the initial release.

Ok. I believe I’m on the latest version. I just reinstalled today because of the no recovery mode issue I mentioned earlier. I’m using 10.11.2. Thanks again for all the help Zach.


I suggest reverting to OS X 10.10.5 Yosemite. It is what I am using on a beauty MacBook Pro Core 2duo.
El Captain still has some bugs that need working out.
I have used and repaired Macs since 1989 and have personally owned roughly 100 of them.
Windose I use with Parallels when I have to and that not often.
Look at the USB cable for a good tight fit, they can be funky.
I have a MBP running 10.6.8 that works good but Easel won’t find the X-Carve so I have to use UGCS with it.
Just retired it in favor of a 2011 MBP that my wife tells me does not go into the shop.

Thanks for the reply Daniel. How can I get back to Yosemite? I tried downloading from my purchases but it says it can’t because I have already updated to El Capitan and can’t go back, or something to that effect.

Support has gotten back with me and I’m gonna see if they can work it out. If not, I’ll be trying to go back to Yosemite I think.