[Solved] Shapeoko loses communication after first project and won't re-connect

I have a Shapoko 2 (no forum so posting in X-Carve) and have been pulling my hair out ever since.
The following is my usual procedure EVERY time I use the Shapoko.

Start Easel, Draw what I intend to cut, enter the COM port and connect.
The project cuts just fine. Try to cut a second time - Easel won’t connect. Shut down Easel, shut down the Shapoko, Retry still won’t connect. Restart my computer “might” connect. Restart everything. Easel connects Start the file and click “Carve” - Shapoko disconnects. -Dick with it - Dick with it- Dick with it. 2 hours later I might get a second cut I might not.

II have to go through this process EVERY time I use the Shapoko. What I don’t understand is why does my fist project run go just fine and then won’t re-connect after that.

Now for some specifics on things I have tried- All of which has the same results.
Computer running Win Vista.
Computer running Win 7
Computer running Win 8.1
FireFox Browser
Chrome Browser
I have changed the Arduino twice and the motor controller once.
I have tried both versions of firmware
Reboot the Shapoko
Reboot the computer
Reinstalled the Easel local files
Stood on one leg and wore a tin foil hat

I am at wits end here and I am really starting to regret spending the money - there has GOT to be something better. I have only cut about 10 projects that took about 15 min to cut, but 2 hours of dicking with the machine to get it to work. Why does it work the first time and then not work again until I let it set for a week or more, then it seems to work again.

At first I though it was me, then I thought it was the computer, but after the same problems over 3 different computers, two different browsers, different Arduinos there is only one common denominator left - EASEL.

Anyone have any suggestions? Is there anything else better out there? I have a RAMBo board I want to hook to it and see if that works better. I can’t believe I am the only one with this issue.

That sounds really frustrating! Easel allows you to export your gcode (under Machine -> Advanced -> Generate g-code, and then Export g-code). You might try doing that, and then trying to run your gcode in another tool like Chilipeppr or UGS (make sure to close Easel first).

Hopefully that will get you over the hump, and maybe some other people can weigh in on how to figure out what’s going wrong when you’re trying to do multiple jobs in Easel (assuming you don’t end up seeing the same problems with one of the other apps).

Don’t know if you want to hear what I think you should do but here goes.
Scrape easel, scrape the Arduino, scrape trying to run a CNC machine via the internet. scrape your stepper drivers.

Get a Gecko G540 4 axis driver. Get a computer that runs XP and has a parallel port. Get a copy of LinuxCNC and convert the computer to Linux. Get a free 2D CAD software. Get CamBam CAM software.

Learn the CAD and CAM programs. Set up LinuxCNC for your machine.

Once you have every thing set up you will be able to run a part, put next material in hit run again and so on till you have as many parts as you need.

Is all of this cheap and easy no it is not but you will not run into the problems you are having now again.

Dave

What version of Grbl are you running?

I have actually thought of that myself David. Thanks Although I was thinking MACH3

I’ve tried both

Glenn

I ran Mach3 for years on my milling machines. The trouble now with Mach3 is the developers are no longer supporting it. They have moved on to Mach4. Mach4 licence runs $200.00.
Linux and LinuxCNC are both free and continue to be supported by the team that developed them.

I have a computer sitting in the shop with Mach3 all set on it that I could hook up to my X-carve when it arrives in I get it assembled.
I also have a computer that is set up with LinuxCNC just waiting for the machine. I have some learning to do but I am thinking that linuxCNC is going to be the better of the 2.

Dave

Hi @GlennBerden I’m really sorry you are having problems. This sounds very frustrating.

A couple of questions to troubleshoot the problem:

  1. What version of GRBL are you using?
  2. What method did you use the flash the Arduino?
  3. Have you tried Universal G Code sender? Does that have the same issue?

@GlennBerden I have not had much luck with Easel yet or Universal Gcode Sender. I switched my Gcode sender to GrblController http://zapmaker.org/projects/grbl-controller-3-0/ then the newer version found here https://github.com/zapmaker/GrblHoming.

I have been able to achieve very good repeatability with it and happy I found it. It runs well on my low power Asus EEE 1ghz Atom 2gb ram with Ubuntu 12.0.4.

Personally I would switch to a Linux based machine to run the Shapeoko/Xcarve. The usb ports and serial communications have been stable and Ubuntu is free.

I have tried both versions 8 and 9,
I Used what ever program was specified in the instructions for the Shapoko - which I can not find anymore becasue they seem to have whipped out any and all support for the Shapoko. I first loaded the new version 9c or something early on - but there was issues with that so I went back to the older version which worked better but still have the communication problem.
I will try a different Gcode sender later this week and see what happens.

The key is we need to isolate where the problem is coming from by only changing 1 variable at a time. At first glance it seems like something isn’t cleaning up after itself properly (port not closing, etc.)

To figure out the source of the issue it is going to require isolating which thing is causing the problem. First thing to do is try other software. If it is happening across different software. If the same issue is happening across different pieces of software we can likely rule the software out as the issue.

If you’d like to do a call to review the process or the steps you’ve tried so far let me know and we can get that set up. I’m sorry again for the frustration. I know this is not a fun situation to be in. I’ve been in it myself over the years with all sorts of different products. For some reason nothing ever works on my computer either. :smile:

Version 9i of Grbl is the only version that would function correctly for me.

Sorry to hear you’re having issues. As the Grbl lead developer, I can tell you that Grbl is rock-solid stable. There are reports of people running jobs with 8 million lines of gcode without a problem (3D surface milling) and at very high federates exceeding 25,000 mm/min.

For the most part, roughly all of the issues I’ve seen with Grbl has to do with electrical interference. For example, if your USB cable is laying next to your spindle cable or other powered lines, the electro-magnetic spikes can cause a USB connection to drop, corrupt the serial data stream to Grbl, and do other weird stuff. I’ve also seen when a computer/Grbl is sharing the same circuit as the spindle or florescent lights cause problems. It varies greatly from setup to setup.

I always suggest to users having problem like this to remove all external influences. Try running Grbl with only the Arduino. No gShield or extra wiring. See if it runs the job successfully. It usually does. Then add things one by one until you find out what’s causing the problem by process of elimination.

2 Likes

I use GRBL (free) with arduino I use po trace and F engrave (all free)I use gcode sender and it works perfect my mill is a mini robo ,this also works on my homebuilt pen plotter ( I change the settings in GRBL for each device)and this setup runs on anyhink all the way back to my old win XP,runing on a gateway computer,listen all this hype about running a CNC or 3d printer on line is BULL just a pipedream in some talking head who is still trying to make it all work,also you do need to have a firm understanding of what you are doing and how everythink works,get some books read and learn first ,yo must not only understand computers but also CNC and electronics at a high level,I have a masters in science…WCH

Thanks for all the help everyone, Inventables sent me the latest firmware and I re-flashed the Arduino and things run much better now. I did loose communications once and had to restart Easel, but I was able to cut 3 projects one right after another. The whole thing ran much smoother than before. So hoping that takes car of things for now.

Time is limited but will try to play on it again soon and post more results. Thanks again

@GlennBerden two questions:

  1. Can we consider this one solved?

  2. How can we make the title more descriptive for someone having the same problem?

1 Like

Sure for now but I haven’t had a chance to do much testing.
Change it to “Shapoko looses communication after first project and won’t re-connect”.

1 Like

Hi there, I am having the exact same problem. Can you please provide me with the steps you took to resolve this issue. thank you.

update: I have tried with g code sender and seems to be working on now. I feel as thhough it is usb connectivity issue with windows 7. Anyone else experiencing this ?

I re-flashed the firmware on one machine and on a second machine I upgraded to the X-Controller.
Someone emailed me the firmware.