[Solved] Stepper motors wont move

I dont think any power is getting to my stepper motors. I got to the step in the x-carve instructions where I needed to test the motor axis using easel. None of the axis work. The motors dont even attempt to move. When the power is on only the fan and a blue light comes on. I looked on the forum and I believe the green axis lights should be on. They only come on when I move the axis by hand. I think this means the wiring is correct. I have removed the arduino and gshield from the metal housing so I can make 100% sure that the pins are in the right place and fully inserted but still no joy. Is there anything I am missing?

Thanks
Joe

If you have the USB cable plugged in and the 24 volt power supply on then the green lights should be on.

Can you communicate with the Arduino? You can use a terminal program like HyperTerminal or Putty to interact with the grbl software. You could also use UGS or ChiliPepper. I think Easel has a way to do it to, but I don’t use Easel so I’m not sure. See if you can issue a “$$” command (no quote marks) to the grbl software to get the settings.

I will have to look into that and give that a try. Ive never done anything like this before so it may take a while. Thanks

For some reason I cant get universal g code sender to run. I have tried ChiliPepper and it would not connect to the port. I have also tried Putty and when I try to connect to the COM3 port (which is the usb its connected to) I get the message “Unable to connection to COM3 Unable to open serial port”

Did you install the Arduino driver on your machine? What OS?

Mine had me flummoxed until I used the pull-down in UGS to set the baud rate to the highest it has. That was the trick for me, anyway. :smile:

I’m running Windows 10 and the drivers are installed. When I plug in the usb it is recognised and is shown under my ports as COM3. Easel recognises it too when I try to cofigure the machine.

I feel stupid because I cant even launch UGS at all. I downloaded the files but cant seem to open the programe

I wonder if it’s a Windows 10 issue? All I did was download, extract, and run the “Start Windows.bat” file. So far, it’s been totally reliable for me. Odd!

It could be windows 10 thats the problem. I tried running the Start Windows.bat file but it opens and then closes straight away.

Have you tried setting the whole thing into compatibility mode? I’m not sure how you’d go about that on W10, but it might help?

Windows 10 has native support for Arduino. If anything it should be less problematic. If the pins are correctly mounted AND he gets green lights when moving the axes, it sounds like his power supply is not correctly connected or is not supplying its 24 volts or he has a bad shield.

Can you test your shield is receving 24 volts on the correct pins? Do you have a multimeter?

I dont have a multimeter so I cant really test the voltage. All I can say is the blue light comes on so the shield is getting ‘some’ power. The fan also powers up.

It turns out windows 10 is better sutied for arduino so I dont think that could be the problem.

The Arduino draws power from the USB connection, the shield needs the 24V power to run the motors.

Oh right. Could it be a power supply problem then?

Could be. A multimeter would be very helpful. Do you have access to one?

unfortunately no. I should really get one.

You can pick up a basic meter for $10 at Walmart

@JoeWhittaker

Joe, UGS requires JAVA. If you have JAVA installed and the .bat file doesn’t work try double clicking the .jar file.

Do you have your COM3 settings at 115200 baud?

Even if the 24 volt supply is not on you still should be able to talk to the Arduino.