[SOLVED] UGS Window Too Small

Hi guys… I just started using UGS recently and when I open the program the window is super small. I need reading glasses to see it. No kidding.

Any ideas how to make it normal?

Java 7 and 8 don’t have good support for HiDPI screens. You can upgrade to an early release version of Java 9, or switch to the platform version of UGS to fix it.

Thanks @WillWinder. Saw your reply on GitHub. I’ll use the platform version and see how that goes.

Windows 10 machine:

Find java.exe you installed.
Right click -> Properties
Go to Compatibility tab
Check Override high DPI scaling behavior.
Scaling performed by: choose System


That worked! Thank you!

I’m like Tyrion Lannister. I drink and I know things

1 Like

Didn’t say I know things while drinking… we may be more alike than you think

1 Like

Hi Jeremy - i have the same problem. But if i change the settings, the ugs window didn’t change. I already reinstalled the jave. What version do you use? THX a lot,…

I leave this here since I had the same problem and this solution didnt worked for me. The problem was I was modifing the wrong properties, this was the solution. (step by step for those not familiar with windows)

Operating System: Windows 10 64
Laptop: Dell Inspiron 17 - 4K resolution
UGS zip file: ugs-Platform-app-2.0-Snapshot (night build)
Java zip: jre-8u251-windows-x64

  1. Open UGCS (it will look tiny - don’t worry)
  2. Open Windows Task Manager
    a) press windows key,
    b) write “Task Manager” (without quotes). Should appear as the first option
    c) click to open the app
  3. In Task Manager, first tab “Process”, under “Name” column, Find UGSPLATFORM in the running processes (in my case ugsplatform64) .
  4. Right-click it and select properties
  5. select “compatibility Tab”
  6. Click on “Override high DPI” scaling behavior.
  7. Check the box “Override high DPI scaling behavior”. This will allow you to select “System” under Scaling performed by
  8. Press Ok, and ok to exit
  9. Close and reopen UGS
1 Like