[Solved] Wires seem to be fine, no motors are moving

I recently completed the build and wiring on my 1000mm x carve and the x,y and z motors to not move, make noise…nothing. I checked all of the wiring and it looks identical to the build notes. There is power to the spindle because it turns on with that switch. Help! Could it be tight belts? I read something about the power to the motors and possibly increasing the power.

I just want it to start running after I spent all that time building it, lol.

What lights do you see on, on the gShield. With USB plugged in and 24 power supply turned on you should see a blue led and three green leds on.

I could be you need to adjust the current up on your gshield. It’s the 3 tan flathead screws, and they are labeled x,y,z on the circuit board. Only adjust up clockwise small amounts at a time.

The blue is on and the green ones turn on when I push on the x or y axis. I’ll try adjusting the current on the gShield and see if that works.

It’s worth a try, but the green lights should be on.

I increased the current on x, y and z and that did not work.

Ok. Make sure that the gShield is plugged into the Arduino correctly. I had to do it several times to get it right. It’s very easy to plug it in wrong since you can’t see inside the case.

I was able to see the inside and the pins seem to be inserted correctly and all the way down. None of my wires are touching each other and everything looks like it is correct. When I turn it on, the only light is the blue LED, the green x, y, z lights only go on when I push the x and y manually.

What operating system are you using on the computer attached to the Arduino?
Does the OS see the Arduino?
Can you access the Arduino through a COM port?

I am accessing Easel using a Macbook.

Ok. It’s been many, many years since I did any work on Apple products so I can’t help with that part of it. Seems like you are having issues with the Arduino. To trouble shoot that you need to find out why you can’t talk to it, or why it’s not working when you do.

call inventables, you need to flash drivers.
put spindle on logic so machine can operate

Thanks for the input! I called inventables and they directed me to the page where I can reset my Arduino.


“How do I wipe and re-flash Grbl to my Arduino?”

I’ll try this tomorrow night and see what happens.

I’ve been having some arduino issues myself, and found that this hex file (0.9i) worked best:

I tried downloading the github repo and uploaded it using the arduino IDE and it was 0.9j. Dunno if that makes any real difference, but 0.9i appeared to work better for me.

If you don’t want to go into trouble, stay away from new Beta versions for a while. Let Pro guys experience first. Stick with 0.9i.

I wiped and reflashed grbl last night and the motors are still not moving. I sent an email to customer success with pictures of my wiring. I also noticed that at a certain stage in the reflashing, the instructions told me to choose a folder and then once I did, there wasn’t another file that seemed appropriate to choose.

I opened the folder but wasn’t sure which one to choose after that.

Do you see couple post above. There is a file name and link. Did you try clicking on it.?
grbl0_9i_X_Carve_500mm_ACME (1).hex , when you click, downloads immediately.

grbl0_9i_X_Carve_500mm_ACME (1).hex (80.3 KB)

Alan, thanks a lot! I’ll try this when I get home and report back (fingers crossed).

I hope hex file is the only problem you have. Sometimes you have to erase eeprom by sending eeprom eraser. Let us know if it doesn’t work. No panic. :sweat_smile:

I downloaded the hex file but was not sure how to load it after that. My computer was asking me to search for an application to open it under. I tried to choose Arduino but that didn’t work.

I tried clearing eeprom, and then arduino and reinstalling and adding the zip library again… didn’t do anything. Customer Success suggested that I may be missing a folder in my arduino program files but was not specific as to which one. He suggested that he take control of my computer but their offices close by the time I get home from work. I asked for step by step instructions because I have no clue at this point. Very frustrating.