[Solved] X-Carve enlarging image

My X-Carve acting bad, anything on the Easel drawing or VCarve pro drawing enlarging output 8 to 9 times bigger when its carving.
Support sent me hex file, no help. All control fine, homing is good, machine setup is good.
GRBL Controller, Universal Gcode sender and Easel doing same thing. Output image is huge, hitting side wall.
Heeeelllpp.

Could it be mm vs inches? I find when using Aspire (same vendor as VCarve) I need to keep everything in either mm or inches. This includes the Post processor file and the tool selection.

Just a thought.

I’m using inches Keith.
Besides, I’m drawing 10X5 rectangle in Easel, starting to run football field.

One more stab at it Alan. There is a jumper setting on the shield for the steps per inch. Please see https://github.com/synthetos/grblShield/wiki/Using-grblShield#setting-motor-current look down by microstepping.

Edit: And it says with no jumpers it is 8X!!! Sounds like what you are seeing?

I checked one more time, no jumper. Also it was running fine, I tried couple of hex files to make universal Gcode sender to communicate. All screwed. Technical support sent original hex file, Xloaded no good. I think I don’t know how to flash it back to zero statement. I load simple blank file from Arduino then reset, load new hex, no good. Everything good except my machine became football star.

And did you try running the Easel setup again? http://easel.inventables.com/setup

Yes I did.

Mine is just finishing a cut, once it does if you like we can compare the config output of the UGS. Just PM me at Elcanadian at Hotmail.com

Now lost all stepper motors and spindle auto on. Only Keith tried to help that’s it.
Tech support not responding, it’s been 10 days digging problems. Did I make a wrong decision???
X-Nocarve sitting on the table, waiting someone from Inventables to respond. Any body there??

I have the same problem wee needs help :frowning:

In universal Gcode sender, type $$ in the command line and paste the output you get. Also, take a picture of the top of the Gshield and attach that picture to the post.

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.000 (junction deviation, mm)
$12=0.000 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=64 (homing dir invert mask:01000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=244 (homing debounce, msec)
$27=50.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=320.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=200.000 (z max travel, mm)
ok

Your settings are REALLY screwy, you might have flashed it improperly, or the firmware was corrupt somehow.

Go to Open Source Design Documentation
Get the compiled hex from the bottom, and follow the flashing for Windows steps on https://github.com/grbl/grbl/wiki/Flashing-Grbl-to-an-Arduino

After that, post the $$ output.

It looks and sounds like you are designing in inches and Grbl is in mm! Have you tried to type G20 in the command bar inside UGS?

Hi @AlanDavis I’m sorry you are having problems. I think @Johanen is correct it appears the hex file is corrupt. It seems like your GRBL settings are messed up. You need to connect with the Baud rate of 115200. You need to load the hex file listed above.

Have you tried doing the Easel machine set up? This should allow you to change the directions of the each axis and test the limit switches. After flashing the hex file I would close UGS and start here: easel.inventables.com/setup

Then run a test job in Easel and report back.

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.000 (junction deviation, mm)
$12=0.000 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=64 (homing dir invert mask:01000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=244 (homing debounce, msec)
$27=50.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=320.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=200.000 (z max travel, mm)
ok

Nothing changed on file $$.
Try twice.
And I don’t know what to do with that config.h file.

Mr. Kaplan
After hex upload, still no movement on X, Y, Z axis steppers.
Only Spindle working if flip toggle switch up. I think something wrong with my G-Shield.
Since I put this machine together, I carved one desktop name plate, and that was big challenge also. Never want to start from 0,0. I had to put my material where ever machine wants to start. That is it. Please check my receiving date, Still working hard to make this machine running. I’m almost ready to give up.
If it takes to replace GShield and Arduino, I will do that. Please go ahead and send them. You have my credit card information. Send me short message if you don’t have it.
Thanks again.

Hi @AlanDavis I think you are having a firmware / settings issue. Can you please hang tight while we ask our engineering teams some questions? They have gone home for the night but we should be able to help you through this tomorrow.

I was just told our customer success team is also in communication with you on this.

1 Like

Looks like you may have a bad arduino uno. If you were able to load the hex successfully, it should have changed those values. The Gshield allows the Uno to drive the steppers and gives you easy places to wire things to, and wouldn’t cause issues with this part of the configuration.

You followed the XLoader guide from the link I posted, yes? What com port and speed setting did you use when loading the hex file from the Design documentation page?

1 Like