Inventables Community Forum

[solved] X-carve stopped working after Easel upgrade

I have a SO2 that I upgraded to the x-carve. I’m still using the arduino and gShield. The machine was running fine last night, when Easel asked me to upgrade. I clicked yes and now the machine is nearly a brick.

When it is powered on, the fan spins but I can freely move the carriage on all three axis. This leads me to believe that the stepper motors are not getting power. However, nothing I can think of that I did should have affected the electronics. The correct lights light up when i move the carriage, so my motors are still connected.

Nothing changed with my electronics. I’m at a total loss.

My first solution was that i needed to re-flash the arduino. So I followed the directions here

But when i open up Easel and I try to re-setup my machine, I cannot jog the axis.

Please help

OK, when i went there and tried to copy, I clicked the “show status” check-box. I guess I’m in an “Alarm” state?

$132=-0.000 (z max travel, mm)
$131=290.000 (y max travel, mm)
$130=290.000 (x max travel, mm)
$122=0.000 (z accel, mm/sec^2)
$121=-58162.952 (y accel, mm/sec^2)
$120=0.000 (x accel, mm/sec^2)
$112=-2147483.648 (z max rate, mm/min)
$111=0.000 (y max rate, mm/min)
$110=0.000 (x max rate, mm/min)
$102=320.000 (z, step/mm)
$101=40.000 (y, step/mm)
$100=40.000 (x, step/mm)
$31=0. (rpm min)
$30=1. (rpm max)
$27=2147483.648 (homing pull-off, mm)
$26=255 (homing debounce, msec)
$25=2147483.648 (homing seek, mm/min)
$24=2147483.648 (homing feed, mm/min)
$23=255 (homing dir invert mask:11111111)
$22=1 (homing cycle, bool)
$21=1 (hard limits, bool)
$20=1 (soft limits, bool)
$13=1 (report inches, bool)
$12=2147483.648 (arc tolerance, mm)
$11=2147483.648 (junction deviation, mm)
$10=115 (status report mask:01110011)
$6=1 (probe pin invert, bool)
$5=1 (limit pins invert, bool)
$4=1 (step enable invert, bool)
$3=63 (dir port invert mask:00111111)
$2=128 (step port invert mask:10000000)
$1=255 (step idle delay, msec)
$0=0 (step pulse, usec)


No homing switches and no axis probes.

If I used Inventable’s instructions to flash grbl, then why would it be wrong? I’m not accusing or disagreeing, just venting my frustration.

OK, i guess I want to keep using Easel and I would like to be able to use Inventables software. I wanted to know why or how to fix what they have done.

Your grbl parameter values are mostly garbage.

LarryM, thanks. How can i check to see if the arduino is bad?

I don’t think the Arduino is bad. You were working before the changes.

Where did you get the firmware and what did you use to upload it.

When i was starting a Carve, Easel asked to update the easel firmware. I just used their software. I then downloaded grbl and used the Arduino IDE to update.

Where did you download it from?

hey phil where is the download menu at in easel. I think I am running an older app and would like to upgrade but I do not see it anywhere. sorry to bother you. thanks

The link at the top of the post.

Ok, that’s most likely the problem.

Let’s get things back to normal.

Down load the .hex file in the link that Phil gave you and use the following procedure to upload that version of grbl into the Arduino. It’s a derivative of the Inventables fork and is very stable.

After you get that loaded in, go through Easel machine setup to get things configured the way you want them.

LarryM, I went here: J Tech Laser integrated with X-carve grbl (Inventables/Master version 1.0c)

but i don’t see a link to the firmware. In your first post you say the update has moved to the “above right” but I don’t see it

It’s here.

Look down the page to where the following line is:

First time users - you really need to read the readme.pdf

Since you are not going to use the laser mode you do not need to read the Readme.pdf, just download the .zip file in the link below that message. Unzip it to get the .hex file.

1 Like


HI @DavidMarkman, so sorry for the confusion. That first link in that support article took you straight to Grbl’s github page and was meant to provide more general information on the firmware itself. I’ve gone ahead and removed that link to avoid this issue from happening in the future.

The link in the third paragraph takes you to the correct version of the firmware:

For those attempting to update either firmware or Easel Driver and run into issues, please contact our customer success team directly and we’ll work with our developers to get things fixed as quickly as we can.

1 Like

@LarryM and @PhilJohnson, using @LarryM’s grbl software worked like a charm. Thanks so much. I really wish i knew why the official Inventables grbl software did not work. @JohnHayes, when i followed the new link, downloaded the inventables fork, and uploaded using arduino the machine did not start up. As soon as i used xloader to load @LarryM’s software the machine turned right on.

Thanks again guys