[Solved] X-carve won't connect to easel

Hi, I have just finished setting up my 1000mm x-carve and am having trouble getting it to connect to easel. it says that i need to manually specify the com post that the machine is connected too. I have tried looking in devices and my machine does not show up however there is a new device called ‘unknown’.
I am running windows 8.
I would really appreciate any help that you have on this since i’v done nothing but i’m all out of ideas!

having another look at it the problem may be that my ardiuno is not flashed with grbl? I know that some other users have had this problem in the past…
is there any way to check if its already flashed with grbl?

Hi Henry,

I just replied to you in the Easel help system. Here is what I wrote:

Have you installed the Arduino drivers? That is required for Windows to recognize the Arduino. If you haven’t installed them yet, you can do this at the following URL. I would unplug the USB cable before installing. Be sure to stop right after installing the drivers and before flashing any programs to the Arduino. Going all the way through their instructions would wipe out the pre-installed grbl firmware by running an example program.


After installing the drivers, you might need to restart your computer. Then you can try plugging in the device again, and it should show up as an Arduino device.

​Let us know if this helps.


1 Like

I have been going back and forth with the laser upgrade and recently have had issues with gaining control through Easel. JeffTalbot’s note mentions the same recommendation as one of the last steps in the process of the build. So what happens when you flash another grbl or other program to the arduino? Loss of control by Easel seems to be my result. Is there a recommendation on how to return it back to step 1, out of the box, ready to use X-carve? Is there a particular file to download which could be uploaded via x-loader or other program?

thank you very much!
I am a bit of a rookie when it comes to this sort of thing!

We have just created a fork of the grbl github repository that includes our changes to the config file:

We will also be creating a place where we upload compiled hex files. In the mean time, you can use this repo to safely compile and flash grbl for X-Carve using the Arduino IDE.


Thanks again JeffTalbot.

That’s a great help!

after uploading its not give me the correct size of cutting

can you explain to me how to set up the grbl again becuase i lose it

1 Like

I’m having the same issue. Easel is taking my small project and scaling it 10X or so.