[Solved] Y Axis lagging on one side

Hey all, finished up my machine (1000x1000) today and everything is ok except for one issue. One side of my machine is lagging when you switch directions on the test screen in Easel. I have loosened the belts, tightened the belts, adjusted the eccentric bolts on the gantry, tested all wire connections, tested each stepper motor, made sure the unit is square, tested the pulleys to make sure the set screws are tight, changed the potentiometer settings for the Y axis (default out of the box seems best, so left it at that. I’m at a loss and am finally asking for help :). I’ll post a vid in a few so you can see what is happening. When you go in one direction for a couple steps it work fairly well, but when you switch directions it’s like one side takes a break for one set of instructions then catches up. Ideas? Help please :slight_smile:

FYI, the assembly is mounted to the table via screws, very solid.

How’s the tension on your V-wheels? You should be able to turn them by hand with a small amount of force, but they shouldn’t just spin freely. If you try to turn one with your finger and the carriage wants to move with it, you might back off the eccentric nuts just a hair and see if that changes anything. It wouldn’t hurt to knock the Y-axis current settings back up a couple of ticks marks too - it seems to vary a little from board to board, but allowing a little extra has helped a lot of people with similar problems (after ironing out mechanical issues.)

Aside from that, it looks like you’ve covered all of the major points. Give the V-wheels a good inspection, see if anything needs a little tweaking, and keep us posted! I (fortunately) haven’t had any trouble with mine at all after spending a fair amount of time on those particular adjustments.

Thanks Timothy, I just did another lap around the v wheels and are are set to spin with a bit of force as in the instructions. I also just did a random pattern cut (without bit) to find the current limits via the potentiometer for the Y axis and settled on what seems to be the sweet spot. I think I’m done messing with it tonight, will take another look tomorrow and do another lap around the entire machine. That is after I hit the inventables market as the homing test just nuked the limit switch on the Z axis. Worked the last two times I ran it, but third time seemed to be the charm…crushed. Good times.

If it makes you feel any better, I smashed my Z switch today too during a moment of inattention. :smiley:

Rest on it and start fresh tomorrow - it’ll work out!

New data, took the belts off for kicks and ran the Y axis in one direction. Result was pretty surprising. The Stepper motor on the ‘slow’ side just freaks out. Will take another look at the wiring tomorrow, but it’s definitely a motor / wiring issue.

Looks like the problem i have. try and disconnect the stepper motor, and short one pair at a time, check that the motor resist turning by hand. Mine had a broken link inside, so when i shorted a specific set of leads, there was no resistance.

edit: spelling

I had this exact problem and found that the blue wire had come loose and was touching the green wire next to it! I would probably unwire that motor fully and try to re wire it!!

1 Like

Bingo, used crimp connectors from the stepper motors to the power ‘bus’. The BLUE WIRE was loose in the crimp housing. Thomas called it, +50 bonus points for problem diagnosis, +1437 bonus points for calling the exact wire lol.

Thanks all, running very smooth now.


Awesome!! Im glade you were able to find the problem. And Im glade I was able to help!!

wow simple fix. it was my problem too. wire came lose. thank you guy for taking the time to post.

1 Like