(Solved) Z axis not cutting to proper depth

Can’t get the Z axis on my x carve to cut any deeper than about 1/2" no matter how deep I tell it to cut.
I’ve tried moving Z axis by hand with power off and it functions just fine all the way up and down. Trying to get through cuts on 3/4" wood, and it just isn’t happening.

Please share your project to start.

Project isn’t anything really. I was trying to cut some motor mount adapter rings for a model rocket engine. Just some simple circles with holes through the center.

I just wanted to see your set up as a start

Also, if you post your parameters from the machine inspector, Larry would spot problems right off the bat.

What parameters? I guess I don’t understand. I go to Machine tab, but it doesn’t tell me much. What all am I needing to provide?

machine->advanced->machine inspector will bring up a long list of parameters. you can copy and paste into the forum.

difinitely post a sample project by sharing with link. Make sure you click save or we won’t be able to open it.

I set the machine to raise the bit in 1" increments, and all it moved was 1/4". Also picked up an issue with the x axis now. Green light comes on and buzzes intermittently with machine just sitting still and no commands being given. X axis motor is REALLY hot and making intermittent grinding noises when given commands to move.

does any axis move correctly?

y axis works fine

turned down pot on x axis and that seems to have solved that problem

Still only getting 1/4" of movement on Z axis with step interval set to 1.0"

Here’s a screenshot from machine inspector.

Select and copy/paste the whole list.


In your machine setup, do you have the correct screw selected? (m8 or ACME)

yup. selected acme. I just measured again and am now getting exactly 1/2 of my step interval. I checked the jumper and it is in place.

Sounds like you need to check the micro step jumper for the z axis on the Grbl shield

It should be jumpered for 2x stepping