[SOLVED] Z-axis reverses direction randomly

Having a problem with my z-axis. Using UGS I send the command to go down or up a few times consecutively. First few times, the motor responds normally, then for some unknown reason, it reverses direction. After that, it starts behaving erratically and will go up and down randomly regardless of the direction command. I tried tweaking the potentiometer as well as trading out the motor for a different one, but the behavior is the same regardless of the motor used and pot setting. Any ideas?

I’ve seen that from others and it was a loose motor wire.

1 Like

I will check the wires connecting the gshield to the post and reply back. Thanks for the help!

1 Like

Well, I double checked and the wires connecting to the gshield were a little loose. I tightened it up but the issue remains. I’m starting to think it’s a problem with the gshield.

Not likely. Also check the wiring to the Z motor at all terminal points. Look for loose screws, strands of wire shorting to its neighbor, etc.

To eliminate the gShield as a problem, temporarily swap the X and Z axis at the gShield and check the results. Does the problem stay with the Z axis or does the problem move to the X axis?

1 Like

Guys thanks for all the suggestions. I switched Y & Z and the Z motor behaved normally. So I rewired everything back up as original and now it’s all working. Not sure what I did differently, but it’s working now so I’m happy :slight_smile: Big Thanks again!