Speed when NOT cutting

I tried a few searches, but I’m not sure how to ask this question:

How do I maximize my stepper motors’ speed when the G-CODE is NOT in a “cut,” – in other words, when it’s changing position “above” the work piece.

Is this controlled in the G-code or in the GRBL sender? I’ve played with the GRBL setting a little, but it doesn’t seem to give me more speed when “changing positions.” I can easily control the speed when cutting in my CAM software, but i find no means of controlling the “non-cutting” speeds.

I’m controlling my steppers with GRBL on an Arduino NANO and using Pololu DRV8825.

If you could point me to the question that answers this, or just tell me where to be “messing around” - the pololu, the GRBL, the NANO, the CAM, etc…

Max rapids (non-cutting) is defined by GRBL parameter $110-112 (X/Y/Z).
Another setting that do have impact is acceleration values, $120-122 (X/Y/Z).
The PSU voltage and pitch of screw directly affect feed rate as steppers are RPM-limited.
CAM-software dictate all other speeds, where rapids is absolute max.

What are your machine specs at the moment, like PSU voltage, stepper motors, screw/belts etc?
Intended usage?

Some gcode sender programs provide feed override, but its still limited by $110-112.

IT’s a regular X-carve as far as the machine is concerned with the NEMA 23’s running the GT2 belt – both from Inventables. When we get to the electronics package, it is definitely “Open-source” to the maximum.

The steppers are driven by 24-volt driver “box”

I use a Raspbery pi 3 as my “main computer”
https://www.raspberrypi.org/

on top of it is a Protoneer.com Raspberry Pi hat
https://blog.protoneer.co.nz/raspberry-pi-cnc-board-hat/

Arduino NANO
https://www.arduino.cc/en/Guide/ArduinoNano

the Pololu DRV8825’s
(https://www.pololu.com/product/2133).

My “G-code” is sent by bCNC (which is like cheating, it’s so easy)

My CAM is HeeksCam:

My CAD is Librecad
https://librecad.org/

It’s the least expensive most flexable “package” I can come up with … HeeksCam has NOT been updated in years, but it runs pretty well (but I back-up my work OFTEN due to crashes).

All speeds are dictated by CAM, which is what generate the tool path/speeds.
GRBL set max allowed feed rate, CAM can generate anything less or equal to the GRBL max rate.

OK, this helps. Thank you. 2 more questions, please.

I went back and looked at the G-code that my CAM wrote yesterday. I also looked up some info on G-codes.

VERY rarely do I see a “F” code! The few places I did see it was when I specifically instructed to machine to run at a specific speed with my CAM software (I.e.: F100 on a vertical (Z) move of a drilling operation). This means there must be a “default” setting either in the “sender” or the GRBL.

After reviewing the G-Code again, I discovered that was the ONLY “F-code” in the whole program.

Question 1:
Surely, there is a way to override the “defaults” at the start of the program??? If I cannot get my CAM to change the “rapids” (the G00 default speed), then surely I can just go into the top of the whole code and manually write it in, correct? but which “F” controls “rapids?” and how/where?

Question 2:
Since my CAM is NOT writing the default speeds (F-codes) could my GRBL sender be adding them in? I use bCNC, which claims at the top of each program that the G-code is: “Created with emc2b post processor.”

My X-carve lives in my “Shop,” not at the house, or I’d be trying this out, but as it is Sunday, I only go to Mass and do family stuff, today (after they wake up – lol).

Sample of the G-code below (not sure about the “tool change” that is shown):

(Created with emc2b post processor 2020/03/28 09:25)
G17 G90 G21
G00 X37.45 Y17 S7000 M03
Z5
G83 Q14 G98 X37.45 Y17 Z-27 R2 F100
X71.45 Y17
X71.45 Y51
X37.45 Y51
X37.45 Y189
X71.45 Y189
X71.45 Y223
X37.45 Y223
G80
(tool change to 3.175 mm End Mill)
T4 M06 G43
G00 X37.447 Y17.193 S7000 M03
Z2
G01 Z-3.333
G02 X37.633 Y17.06 I-0.008 J-0.208
X37.274 Y16.905 I-0.186 J-0.062

… G00, G01, G02, X, Y, Z for many lines, ending with:

T0 M06 M02