Spindle electrical noise causing machine to lose x zero?

So I’ve run into a couple problems with my machine, and seem to have figured and fixed them all but this last one.

I set zero using UGCS, send a file, machine returns to zero. I send a couple files this way, everything cuts just fine and returns to zero each time at the end of the job with the m30 comand. After a couple jobs, the next cut is about 1/4 to the left. And the next job after that is now about an inch to the left. I’m not sure why the machine is losing its x zero. I’ve checked my belts and they are tight.

The above picture shows what I mean. I was cutting a grid of 1" squares with varying speeds and depth of pass to see how fast I could go. I was sending each square as it’s own program. You can see the top square is to the left. The bottom is supposed to be two squares but it’s moved the bottom one over enough they’ve been combined.

I’ve had a couple runs with similair problems, always after the machine has been running for a while, 40+ minutes.

Any help would be greatly appreciated because as of now the machine really isn’t reliable enougj to be usable.

Try nudging up you X pot dial on your grbl board, your X axis looks like it’s loosing steps through each job. Not a noise issue. It’s either the pot or something is loose, belts or v wheels


Check your eccentric nuts. Mine have come loose and caused the exact thing.

1 Like

Yes check all your vwheels, nuts etc. But this happened to me as well. Spindle failed not too long after. Still need to call investable to get a replacement but i am using the Dewalt DWP611 and its a world of difference. I’m cutting maple and black walnut at crazy speeds right now. ill post a pic of some sushi boards i made today… But yes a failing spindle can cause you to loose zero as it happened to me.

1 Like

Also check the pulley on your X stepper motor is tight. The little grub screws can come loose and cause lost steps.

My Z axis does this and even spent a fun afternoon last week sifting through my vacuums bag searching for one when it fell out. :smile:

1 Like

I made some progress, and then it all went away.

I bumped up the current setting on the X axis a touch. Then checked the belts. The belts were tight. I checked all my v wheels and good thing I did. Some of them had worked them selves very loose. Some of them had worked themselves very tight. Like really tight. Tight enough the X axis didn’t want to move easily. I can attribute the loose wheels to turning the eccentric nuts counter clockwise trying to adjust wheel tightness. Even a light turn backwards loosens the bolt right off. How they got so tight? I don’t know.

I adjusted everything and the machine moved around nicely.

I had the power on while I was adjusting the wheels and I could hear electrical noises coming from the spindle when it was off. Is this normal because to me I shouldn’t have heard anything.

I started a small cut and everything went well, ignoring the fact I zerod it .1 above the work piece because I’m an idiot.

After the cut I tried moving the machine around with the UGCS keyboard controls distance sent to .25"
And machine would barely move. I checked the number again and reset it to 1" movement. Again barely any movement. Ugh.

Make sure that UGCS is set for inches. If it’s set for mm your movement with .25 and 1 would be small.

1 Like

I did check that one and it was set to inches. I’d hoped it was that easy. I didn’t spend too much time trouble shooting it at that poit though. After spending so long adjusting the wheels, getting at the wheels on the X carriage is, fun, and then running into a new problem it was time to walk away from the machine.

if you are concerned about spindle electrical noise interference try attaching a pen or sharpie to your machine and run the same file with the spindle off and see what happens