Spindle not going down enough

Ok so I just got my xcarve up and running today it did the test piece had to make some adjustments but it work great after that then I made something else work great now set everything up spindle goes down but never cuts into the wood check thickness it’s tight even tried making the wood even thicker in easel but still doesn’t cut into the wood does anyone have any ideas ?

Are you possibly setting the z zero at the wasteboard in easel, but actually zeroing it on top of the material you are going to cut?

I have not used easel, but I’m sure I read that someone else had the same issue because of this.

If this is the case then it will raise above your set marterial thickness, and then cut air until it gets to Z zero again.
If you set the material thicker it would raise higher still, and would go through the same air cutting it’s way back to Z zero

I figured it out last night my material was not sitting flat at the corner were I was setting my z point it was high so when it went to cut machine didn’t go down enough thank you for you response and help