Spindle not starting - third party machines?

Good evening - trying to make sense of this…

Using third party machine, have gone through all the typical setup of a machine, to include:

Spindle control set to “Hardware”
Spindle type set to “24VDC Spindle”
Spindle RPM set to a default value, as the software isn’t controlling it anyway…

Go through the motions of starting a carve, it goes through all the prelim steps, set home, zero, etc - but then when we click the “Turn on the spindle” button, we get nothing…

Haven’t exported the code to see if it’s missing the M3 command - that’s the next step.

Using UGS or gSender, the spindle can be activated just fine, so it’s kind of befuddling why Easel isn’t turning it on.

Any thoughts? Something obvious that I’m missing? Quirk of a new driver version or something?

Welome to the forums. Do you have your $32=0

Yep - default value on the machine is set as follows:

$0=10 (Step pulse time)
$1=255 (Step idle delay)
$2=0 (Step pulse invert)
$3=0 (Step direction invert)
$4=0 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=115 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=1 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=3 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=500.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=3.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=0 (Laser-mode enable)
$100=200.000 (X-axis travel resolution)
$101=200.000 (Y-axis travel resolution)
$102=160.000 (Z-axis travel resolution)
$110=2000.000 (X-axis maximum rate)
$111=2000.000 (Y-axis maximum rate)
$112=2000.000 (Z-axis maximum rate)
$120=300.000 (X-axis acceleration)
$121=300.000 (Y-axis acceleration)
$122=300.000 (Z-axis acceleration)
$130=600.000 (X-axis maximum travel)
$131=600.000 (Y-axis maximum travel)
$132=55.000 (Z-axis maximum travel)

Well it was a shout in the dark i tried.

Yep - that’s where I’m at - trying to help customers, and it is only impacting some users…

Trying to narrow down if there’s something in the new driver, if it’s related to a specific browser, if the planets aren’t aligned right, etc…

1 Like

Manual or Automatic are the options, right?

What’s the rpm in easel set to?

In November 2021 update this was changed to Manual or Hardware. Manual meaning a human flipping the switch and “hardware” meaning software controlled IO commands (which doesn’t make any more sense than “automatic” did really)

the correct settings for the yorahome machines in that page are “Hardware” and “Other” spindle type.

The “24VDC spindle” option is setup for the Pre2016 X-Carve spindle type and will only output a 1 for the RPM BUT you need it to output the true set RPM, a value of 1 isn’t enough to get yours spinning…
Also Change the $30 to your spindles max RPM setting, likely 10,000
OR you could keep using “24vdc spindle” BUT you’d have to change $30 to 1

1 Like

Thanks, Seth -

I know the 24VDC option had worked on some of the smaller machines, but I didn’t realize that it was limiting the output to just a 0/1 digital value, in essence - that makes sense why we aren’t seeing the relay close.

One of those quirks of software that I haven’t seen documentation on - thanks for the clarification. Will have them change that and see if we get a resolution.

The plot thickens…

Finally got the spindle operating - we weren’t getting anywhere, even after removing the entire machine profile, restarting, and adding a new machine with relevant settings.

After some back and forth with the user, he noted that he was using Firefox on MacOS. Asked him to try it in either Chrome or Safari, to see if the problem followed.

Tried it in Chrome and things work just fine - cue much cursing and gnashing of teeth…

Confirmed that Firefox is the most recent version (108.0.1), and MacOS is at Monterey - so apparently a strange combination of factors in play.

Something to keep in the back pocket for future issues, I suppose…

1 Like

Hi. I am not sure if this is the same problem, but after letting my Win 11 system upgrade the Easel driver this morning, I no longer get the “Turn on the spindle” button. It asks me if the spindle has started, but nothing to turn it on with. Another of my systems which is still at Win 10 shows the button and is craving away as I type. As far as I can tell, the 3rd party machine is configured the same on both systems. Is there some other obscure setting that controls the visibility of this button?

Hey Bryan,

Can you go to Machine>Edit Machine and then verify that your settings are:
Spindle Control: Hardware
Spindle Type: Other
RPM Max: (As appropriate for your spindle and Grbl Settings)

using these settings will allow for spindle control in the manner you desire.

OK, user error. Sorry to have wasted your time Seth.

1 Like

It’s all good. Glad you’re all sorted and back in business :smiley: :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.