Spindle not starting with UGS [Solved]

I have a X-Carve and when using UGS the spindle will not start , all other commands seem to work & the spindle WILL start with Easel… Any ideas?? I’ve tried versions 1.08 & nightly builds of UGS…

Thanks

Kerry

Which Software you’re working. If it is Vcarve, there is modified post processor you can use.

Yes it is Cut2D that I am using I am outputting GCODE using the X-Carve GCode from Cut2D I’m not aware of the post processor …However issuing the M3 or M4 command direct from UGS does not work either.

Thanks

Kerry

Direct command didn’t work on my UGS either. That’s why I add M03 to start, M05 to stop. M04 doesn’t work. That’s for different spindles to turn counter clockwise. Simply open post processor file with note, add commands to beginning end ending.

Here is what is currently in the PP file:
begin HEADER

“T1”
“G17”
“G21”
“G0[ZH]”
“G0[XH][YH][S]M3”

I would assume that would work, are you saying add M03 to the top say before the T1?

Kerry

I’m away from my work PC. Let me look for modified post processor several times previously.

No Problem, thanks for the help!

Kerry

Try this;

https://discuss-assets.s3.amazonaws.com/4096e69bc758e5e3d3da2a685637f9f4694f48fc2b4a.pp

And This one for mm.

https://discuss-assets.s3.amazonaws.com/409504f77886cda2c8cfc6648e4adbd94ea175e1b3b0.pp

Depending on how you have your Grbl set up you may need to send a spindle speed (something like S1000) along with the M3 command.

Ahh the speed entry fixed the direct command! Thanks I’ll try the new post processor tomorrow. It may well be that i need to specify a spindle speed in Cut2d as well…

Thanks both of you

Kerry

OK Those fixed things!! Thanks

Kerry

Very interesting…

I wired mine up… edited the Postp file and it starts automagically like it should, but won’t stop.

I can issue the m5 command from UGS and it turns off. It’s like it is being ignored.

What program are you using to generate the G-code?

Vcarve desktop.

I took the .pp file provided earlier in this thread and it didn’t work. I put the power off in the FOOTER section. I can’t see where it’s being sent to XC from the UGS console. I even tried hiding it in the line where it sends the carriage to home.

When I look at the .gcode file, I don’t even see where the power on part is in there. I’m pretty sure I’m editing the correct .pp file since I used the “open data directory” option form VC. It’s almost as if it’s not being put in the gcode file, but I’m not 100% sure of that.

Use one of the post processors in this thread. Scroll down to find them.

Put it in this directory (change for your program and version):

C:\ProgramData\Vectric\VCarve Pro\V8.0\My_PostP

1 Like

Phil - I used my VC 9.0 to open up the data directory (the xcarve pp file was already there). I edited the file and saved it in Notepad. I did an upgrade from 8.5 to 9.0 several months ago so I wonder if somehow it’s still using the v8.5 PP file instead? I expected to see the M commands in the .gcode file but didn’t. I’m not quite sure how the spindle is getting turned on without it. Maybe it’s squirreled away somewhere and I’m not seeing it.

I updated the existing one so I didn’t need to change the PP when exporting… When I get home tonight, I’m gonna move the new PP’s I downloaded from the recommended thread and will rename them as you suggest. That is a good idea and am a little miffed I didn’t think of that. lol

1 Like

OK. It’s still not working, but I have more info…

1st - I was editing the file in PostP and not MyPostP so it wasn’t working…

2nd - downloaded the Vectric_X_carve pp files and put them in the MyPostP directory for9.0

I had to restart VC before it would recognize it.

I start a carve and the spindle fires up, does it’s thing, returns to home and still runs. The gcode window displays:

G2X1.8023Y0.2834I-1.3998J0.0000
ok
ok

G2X0.4026Y1.6831I0.0000J1.3998
G0Z0.3000
G0Z0.5010
ok

G0X0.0000Y0.0000
Skipping line: M30
ok
ok
ok
ok

**** Finished sending file in 00:00:16 ****

The m5 was never sent despite it being in the .gcode file.

IF I hit the red stop button in UGS while it is carving, the spindle will power off.

If I look at the gcode file, the last lines are:
G0 Z0.5010
M5
G0 X0.0000 Y0.0000
M30

This is very odd.

Everything works fine in Easel, too.

Looks like it might be an issue with UGCS. @WillWinder

Starting to look that way. I tried it on both the Sep and late Nov builds and it neither worked.