Spindle not working DIY 3018 CNC

I’m new at this…
I just put together a DIY 3018 CNC. So far everything works as it should. The only problem is that the spindle doesn’t work. I’ve seen it work twice when setting the machine up in Easel. Both times I clicked to turn the spindle on. It spun for a few seconds then turned off. I was unable to get it to turn on a second time. I’ve checked all the connections and that everything is set up correctly in Easel and Grbl.
Any suggestions would be greatly appreciated. Thanks!

I'm having the same problem. it works then it won't . I even went and bought a new circuit board, connected it, it worked, I thought Great now I can move forward. The next day it wouldn't move. I checked all the end stops, they all worked, no shorts or anything. Checked all wire connections. Made sure the software was connected to my machine. All I want to do is Home it, but it won't.     
Try using different control software like "Universal G-code Sender" Mac or PC, or Pronterface, PC only, or Mach3. Maybe you'll have better luck than me. I gave up now, if I think of something I'll try it. Or, if you were able to get yours running please let me know how you did it.