Spindle on off at start of run

Any know whats up with easel spindle control just before i run the project it says spindle on it comes on as it should then when i start it shuts off while it moves to the first cut then comes back on.

Same problem here. Kinda nerve racking

I thought well this is the end of this bit then the spindle came back on.

I don’t always use easel, but I did a few times yesterday. That spindle off thing right as it moved to start the carve gave me a heart attack. I jumped for the power switch quickly, but couldn’t find it fast because I don’t have an e-stop. By the time I had found the switch, the power had come back on to the spindle. Sheesh.

1 Like

The last time i had a crash I hit the estop and still it travelled another few inches over and down into a half inch of pine then proceeded to embed into the waste board almost reaching the other side lol .5x1.5 inch router bit. Baking soda and super glue makes great waste board patch.

So, is it intentional or just a bug?

Hey all, sorry for the inconvenience.

I’m having some trouble replicating this, could you provide a bit more information? What spindle do you all have (chosen in /setup)? Did you use a roughing or detail bit? When you progressed through the walkthrough, did you go through it without changing any parameters or did you go back and forth frequently?

It would help if you could provide a link to a sample project (or if you are uncomfortable sharing it publicly you can send me a private message).

Again, sorry for the issues!

1 Like

If you click “Something went wrong” and “My problem isn’t on the list” at the end of the job, and submit an error report, that also will help us get to the bottom of it. Thanks!

1 Like

I have the dewalt on a relay. Just doing a standard cut straight through the menu nothing else. When i get home i will make a short vid if that will help.

I had not clicked that anything had went wrong i just thought it was part of the programming. Everything came out fine on the last 3 projects that it had done this. At one point i had thought it was some sort of safety feature.

Dewalt on relay here too. Seems to be a 5volt trigger wire interruption between generate toolpath and actual start of the carve.

I have the same issue when importing gcode. I am running the stock 24v spindle. I get a screen that was not there a few days ago that asks me if I understand about the import. Then when I start the carve the spindle starts I press spindle started button on screen, then when I press carve the spindle stops for a second then restarts and carves normally. I did not that once when I had a small file it didn’t seem to stop and restart. I figured it may be related to the file size. Anyway all the carves complete normally. just an annoyance.

This is what it is doing. I also had the same result with 2 other laptops and a desktop. It has had no ill effects It just freaked me out when it did it because i thought the tool was going to crash with no spindle power then it came to life. and here is the link to the test. http://easel.inventables.com/projects/0HUuNKI6Qd4mLaHOsqroRg
and a vid

I have the Dewalt on a relay as well. Must be a drop in the voltage that trips the relay for a moment perhaps?

I have been using this machine almost daily for around 5 months and it just started doing this. Not that it hurt anything but it freaked me out thought i world be looking at a broken tool and a gouge to fill in. The length of time the spindle stays off is in relation to the amount of time it takes to generate the path. A simple outline is just a quick pulse off and back on just enough to hear a small change in spindle rpm.


Take a look at the generated G code. Look for an S0 or M5 instruction.

here is the start of the code and the end
G1 Z0.15000 F9.0
G0 X5.30753 Y2.65366
G1 Z-0.02800 F9.0
G1 X5.30753 Y2.65366 F1.0
G1 X6.12262 Y2.28156 F1.0
G1 X5.99161 Y3.12054 F1.0

G1 X5.38315 Y2.50241 F1.0
G1 Z0.15000 F9.0
G0 X0.00000 Y0.00000
G4 P0.1

If you don’t have any S0 or M5 instructions in your G-code then Easel must be issuing them itself. Those are the two things that can turn the spindle off.

Actually, any S command with less than 12000 as the argument would affect the spindle by providing PWM pulses to your relay.

This was happening to me last night as well. I have a very similar set up. Dewalt. I have not had it do this before on other projects through easel. This seems to be in the last week.

I have been using my XC for months and never seen this before but this happened to me yesterday on a project I have previously cut without problems. In Easel, with the spindle running, press Carve, as the spindle moves towards the first point it turned off for a fraction of a second and then back on again luckily before contacting the work piece.
XC 1000, Makita controlled by relay using the PWM output.