Spindle on off at start of run

I have the same behavior on a Shapeoko 2. It has been fine since I built it, and only started doing this recently. I assumed it was a change to Easel, not a hardware problem.

My spindle is the generic “dremel” tool the kit shipped with being controlled from an SSR (solid state relay.) I’m still using a 0.8 version of Grbl, not the new 0.9+ version that swapped the spindle control and limit switch pins.

As others have noted, the spindle turns off on the way to the first milling point for a time that seems proportional to the complexity of the carve. So far, it always restarts prior to the first plunge, but it’s unnerving to hear the spindle turn off, with me jumping to and hovering over the emergency cutoff switch until restart.

1 Like