Inventables Community Forum

Spindle stops for no apparent reason

Hi folks.
I’m using Candle with my 1018 CNC.
I’ve just fitted hard stop limit switches, and all work fine.
However, now a strange thing is happening with the spindle.
When I run the spindle, after a very short time (sometimes only seconds) the spindle shuts down with alarm error.
Weird thing is, it only started doing it after enabling $21=1 for the limit switches.
If I turn them off, $21=0, it runs fine with no stopping.
Any ideas where to look?
Cheers.
Andy.

This forum caters to Inventables products, not 3rd party systems. However, many of the fundamentals are the same. Could it be that your switches are mis-wired?

Using the GRBL code $21 requires limit switches be installed and looks for one of the limit switches to be activated which triggers “Alarm” mode. In this mode, all machine motion, the spindle and coolant are shutdown. If one of your switches is stuck in Alarm mode, it could cause this problem.

From what I have read the use of limit switches for hard limits is prone to electrical noise which sets off the alarm.
It seem that soft limits has been the recommendation.

1 Like

OK.
Thanks for that, I’ll look more into it.
Andy.

Hi.
No, all wired and work correctly.
All in normally open configuration.
I’m pretty sure it’s a software glitch of some kind.
I’ll recheck everything though.
Thanks.
Andy.

What error?
@MarkA.Bachman is correct. Your limit switches are prone to EMI and detecting false actives. Why do you need hard limits?

Hi Mark.
Just thought they were a good idea, I have a 60W laser and it has hard stop limit switches, so when it’s initiated, it sets origin to 0.0 without having to set it every time.
I guess I’ll just have to get used to doing it manually at start up.
Thanks.
Andy :slightly_smiling_face:

@AndrewMcintyre You are thinking of “Homing switches”. Grbl has these as distinct settings. Hard limits are to prevent crashes (but cause issues with false triggers when great care is not taken to isolate them). You can use the same switches to “home” the machine, which will give you that absolute reference. You’ll still need to set a Work Zero, which can be anywhere in your work envelope.

Oh Ok, so how do you set them to home without alarm then?

Hard limits should be off, homing should be enabled.
$21=0
$22=1

Your machine will be in an Alarm state when you power up and connect until you home.

Cheers for that, I’ll have a look tomorrow. :slightly_smiling_face:

I’ve seen this happen on mine after I put dust collection on my Openbuilds machine. Static noise sets off of the limit switch. I grounded the dust / vacuum hose and got it to go away. Depending on your limit switches they could be more sensitive to it.

Thanks, I’ll look into it.
Andy.