Inventables Community Forum

Spindle won't move in any direction

The other day after 4-5 carves, everything stopped working. Homing fails. Directional controls in Easel do not do anything. Normally when I turn the power on I can no longer move the spindle manually (the x,y, and z axis motors lock it in place). Now after turning in x-controller I can still freely move spindle.

In the machine inspector, the x,y, and z homing switch indicators are green. When I press on them, they turn white (exact opposite as expected. Someone suggested switching one of the wires to the 3rd pin, which made the indicators work as expected. Not sure why all of a sudden I would need to switch those. Seems like there is something else wrong that caused that to happen.

Homing – Spindle does not move at all. There is no noise like it is trying to move. Just nothing at all. After about 15 seconds, a message pops up that homing failed.
Spindle controls in Easel – no motion, no noise (like it is trying to move). Again, nothing at all.

Need help!!! PLEASE. :slight_smile:

I have tried:
uninstalling/reinstalling drivers
Taking cover off x-controller and cleaning all dust out (nothing looks burned out on the board).
Removing all connections (one at a time) blowing any dust out, and reconnecting.
Deleting and reinstalling the machine setup in Easel.
Rebooting computer.

1 Like

Is the e-stop button pressed?
(Press is to engage, twist and pull to disengage… of your not 100% positive its up. Then press down and engage and then release it… it’ll lift up like 1/4")

Are you sure its receiving AC power?

Missed that in the “have tried” section. I did press the estoppel and pulled back up. Have done that a few time. When engaged it does not co next to the computer. It IS connecting to the computer.
Power looks good. Fan on back of x-controller is on. Fan inside x-controller is on. Green power light on front is on.

Thoughts.
Maybe one of the wires is bad?
Maybe one of the axis motors is bad?
Something inside the x-controller is bad?

Just my guesses at this point…

1 Like

you could disconnect the X and Y steppers on the back of the xcontroller and try to operate just the Z,… and repeat trying one at a time :man_shrugging:
Hmm, (Regarding somthing inside being bad) the drivers are all independent of each other, but I think there is an output from the Power supply up to the drivers that could be bad…

in machine inspector can you verify that they match the default.
I’ve seen where the steps/mm get reset so low that it looks like the cnc isn’t moving…

$0=10 (Step pulse time)
$1=255 (Step idle delay)
$2=0 (Step pulse invert)
$3 = 3 (dir port invert mask:00000011)
$4 = 0 (step enable invert, bool)
$5 = 0 (limit pins invert, bool)
$6 = 0 (probe pin invert, bool)
$10 = 115 (status report mask:01110011)
$11 = 0.020 (junction deviation, mm)
$12 = 0.002 (arc tolerance, mm)
$13 = 0 (report inches, bool)
$20 = 1 (soft limits, bool)
$21 = 0 (hard limits, bool)
$22 = 1 (homing cycle, bool)
$23 = 3 (homing dir invert mask:00000011)
$24 = 25.000 (homing feed, mm/min)
$25 = 750.000 (homing seek, mm/min)
$26 = 250 (homing debounce, msec)
$27 = 1.000 (homing pull-off, mm)
$30 = 1. (rpm max)
$31 = 0. (rpm min)
$100 = 40 (x, step/mm)
$101 = 40 (y, step/mm)
$102 = 188.947 (z, step/mm)
$110 = 8000.000 (x max rate, mm/min)
$111 = 8000.000 (y max rate, mm/min)
$112 = 500.000 (z max rate, mm/min)
$120 = 500.000 (x accel, mm/sec^2)
$121 = 500.000 (y accel, mm/sec^2)
$122 = 50.000 (z accel, mm/sec^2)
$130 = 790.000 (x max travel, mm)
$131 = 790.000 (y max travel, mm)
$132 = 100.000 (z max travel, mm)

Getting closer.
There were a few values that were different. I changed those and now the machine homes successfully.

I click the card button and get to the z-probe step. Connect lead, attach clip, touch plate. All good. Click start probe and nothing. Spindle doesn’t move. After clicking stop probing, I start over from the carve button and it wants to home again. Get to the same point (start probe) and nothing happens.

1 Like

Hope this helps:
I skipped the homing. Manual instead of z-probe.
It is currently carving.

Certainly not fixed, but at least I can carve.

Does this make any sense?

1 Like