Inventables Community Forum

Spindle work, steppers wont turn on (3018)

any idea why my stepper motors dont work they wont even turn on but my spindle works ?
i have a 3018 machine

With power off, feel the resistance on the steppers.
Compare this with power ON, are there any difference?

Do you hear a faint “jolt” from the steppers when you power on?
(Jolt come from steppers being energized and lock onto its nearest step position)

there no difference when power on then turn it off
i dont hear a noise from motors or jolt

I assume the spindle get its power from the same controller board as the steppers?
If so the PSU is working but the steppers do not for some reason. Thats difficult to troubleshoot without physical access.

Do you have a voltmeter on hand? You need to measure if the stepper drivers get power and start eliminating possibilities.

yes spindle works from same controller ive been using easel software and my spindle works
when i first built it i used easel then then everything was fine motors worked spindle worded but then i had to change computers then i cant get motors to work now i dont know what i did different, sorry my memory not as good as it should be im just getting over a stroke

I had the same issue as you. I have a 3018 mini cnc. Only had spindle control. I must have got my firmware corrupted so I reflashed new firmware and it worked perfect. I also flashed the upgraded firmware from .9 to 1.1.