Squaring & Calibration Logbook

So I believe I am entering the home stretch of the squaring process for my 1000mm^2 XCarve build.

I followed this great advice on squaring the Y rails front to back and diagonally. So those Y rails are now square.

However I’m noticing that the Y axis shoulder plates are all slanted inward, pictured below is the worst offender… However the other 3 are very close, and all slanted outward as well. Which creates a degree of twist on the Y axis rails which need to be flat so the V wheels are traveling along the edge of the rail…

What have people done to correct this?

1 Like

Plate edge doesn’t matter…is the actual Y rail face similarly off vertical or twisted in the YZ plane? And I mean relative to the wasteboard face not the surface the wasteboard is sitting on, unless you know it to be flat and coplanar to the wasteboard face.

1 Like

@RichardRemski, Good point, using the square against the Y rails from the waste board reveals much less of an angle.

I made a quick video of the noise I’m getting when the X rail is moved along the Y axis. When moved slowly there are a couple spots in the middle where it seems to encounter resistance. When moved quickly it makes all sorts of noise.

When I move the gantry along the X rail, at any speed it’s just quiet belt noise.

This is why I was looking for out of square rails / components…

Perhaps I’m just approaching the calibration of this machine incorrectly? What should I be doing.


Using a square from the inside of the wasteboard to the Y rail:

  • Right hand side (w/o drag chain), touches at the bottom, can slide 2-3 pieces between top of rail & square.
  • Left hand side (w/drag chain), touches at bottom, can slide 1-2 pieces of paper between top rail & square.

I’m not sure if this could cause the noise described in the above video or not… But the rails are very subtly angled outward.

Another thing I noticed is that if I place gentle upward pressure on the X rail as I slide it back and forth along the Y rails, the noise will go away.

1 Like

When I push the gantry, I try to use 2 hands and put them near the Y-axes. If I only use 1 hand, especially if the hand isn’t in the center, mine will make the same noise. My guess is that it’s because slight differences in friction on each side will cause it to “wobble” forward. Maybe the belt tension is slightly different, maybe the belts have slight variations in thickness, maybe the stepper motors provide slightly different amounts of counter-torque.

I’ve never noticed a problem during regular operation though. I’ve just chalked it up to the design, and I don’t worry about it since it is only apparent when I move it manually.

1 Like

Thanks @RobertA_Rieke, ended up adjusting those eccentric nuts some more and was able to further minimize the noise.

I went on to using Easel and as you mentioned the noise wasn’t at all apparent when being driven by the stepper motors.

This was my second cut which turned out pretty well. 50x50mm box with a 50x50mm circle; both outline, interior profiles. The box came out to 48.85 wide and 49.75 tall, so quite close for a first attempt.

Something is off with the Z axis however, as my depths of cut were 1mm for the box, 0.5mm for the circle, and 0.2mm for that triangle in the middle.

I ended up measuring the Z depth at: 2.05mm DOC for the square, 1.38mm for the circle, and 0.85mm for the triangle. Onto more reading!

1 Like

I have exactly the same sorts of noises pushing in Y, either the belt is thrumming a little or the rails vibrate a little…it’s difficult by hand to push evenly so both sides move exactly the same. I know I’m a tad out of square (the two diagonals aren’t exactly the same, but it’s hard to be sure how much of that is measurement error) although I’ve started doing some early jobs regardless. I am not so far having any lost step issues in Y doing projects, then again I’ve only milled soft stuff like foam so far so I hardly had any ‘sideload’ on the bit or material drag. I upgraded my wiring to 16awg so I haven’t adjusted stepper current up yet, or attempted any calibration of steppers or anything. (Just using Easel so far.)

I did hear this loud almost chattering sound at intermittent intervals while carving out a 24 x 10 inch sign …sounded like a loose metal washer or something vibrating against metal, and I could’ve sworn it came from the vicinity of the carriage. I didn’t think my stock spindle could be going bad YET… I tried touching the limit switch levers, vwheels, the extrusions, belt, drag chain, etc. but none of them stopped the sound. It was definitely louder in either positive X or negative Y movement (and on longer moves) than other directions. I watched carefully because it did seem to modulate related to changing direction of motion but it sort of lagged the actual stepper actuation and pulley rotation, it wasn’t timed right along with a motor starting or stopping or visibly slowing down. It was driving me NUTS. I finally looked back in the back corner of my wasteboard and saw I’d left my aluminum framing square laying on the wasteboard, outside the current clamped down material area, and it was ‘walking’ around on the wasteboard. Every time direction changed I guess the vibration resonance changed and it moved/slid a bit. Picked it up and the noise went away. Man was THAT a relief. :smiley:

I know I’ve got a number of square issues to sort out myself so I’ll be subbing this topic in case you find anything or elicit a response that can help us both. So far sticking to easy projects with foam since a) it’s practically disposable and b) its nice and large so pretty easily shows out of square issues in XY or in depth of cut without runout or bit loading compounding things. (I’m assuming it’s thickness is pretty uniform which might not be entirely safe, but I’ve calipered in several places and the 24 x 24 x 1 sheets seem within about 0.05" as long as you have them clamped flat so they don’t bow…)

1 Like

@Chris314, is your X-carve set up with the proper Z-axis screw? If you have the M8 but it thinks you have ACME, or vice versa, you will get the wrong depth.

It may also just be a Z-axis calibration issue. If you have a dial indicator, you can fudge a mount and attach it to the spindle mount, then calibrate the steps/mm. You can calibrate the X and Y axes also, just need a known accurate source (such as a large steel rule) to compare it to. I ordered a 600mm Shinwa rule for $30 off Amazon, and it’s fantastic.

@RichardRemski, you can calibrate the steppers in Easel. Check out this forum page: Z axis not accurate

There’s a link to the procedure to calibrate X and Y on there, and I’ve got the procedure for how to adjust the settings in Easel a little farther down.

@RobertA_Rieke - Good call! I goofed up and configured Easel with the M8 screw when I ordered the ACME lead screw… Going to go reconfigure and try another cut.

Do you have any suggestions regarding the rectangular cut being 2% shorter (48.80mm to 49.75mm versus 50.00mm)?

1 Like

Glad you got it figured out. :smile:

The rectangle is probably off because it’s not accurately calibrated yet. You can calibrate the steps/mm of the stepper motors in Easel. There’s a video for a good procedure and some instructions for changing settings in Easel in this forum: Z axis not accurate

1 Like


Thanks for your continued help! I followed those instructions; and re-calibrated the X axis. I moved it 500mm; and measured 508mm.

500/508 * 40 (steps/mm) = 39.37007874 steps/mm
$100 = 39.37007874

So I was going to repeat this in the Y direction and I ran into this problem…

In short small repeated small movements of 10cm (100mm) are fine; however one large movement of 500mm results in a small initial movement and then nothing. The machine believes it has traveled 500mm based on the workspace coordinates; and subsequent commands to move the Y axis in smaller increments (100mm) continue to work fine…

Is this a Y-Axis belt issue? Tried to reproduce this on the X axis and no dice.

Resolved: Y Axis belts were loose in the video. I retensioned the Y axis belts; and added a ziptie to hopefully prevent future detensioning

1 Like

@Chris314, I agree with @AngusMcleod that it sounds like something is slipping. After watching to see if the pulley moves, you may want to inspect the teeth on the belt to make sure you don’t have a spot where they’re worn off. If the pulley is spinning, you probably need to increase tension on the belt a little bit.

I doubt it, but it may be a potentiometer issue as well. Is your Y-axis pot dialed all the way up or down? It may be hitting a thermal overload if it’s dialed too high, but I remember the sound from testing as being more like a crunching, like brakes being slammed on and then taken off. Scary sound.

@RobertA_Rieke & @AngusMcleod, thanks for weighing in.

I went back to investigate. The belts are looser than they were at the beginning of the day; lost that guitar string “snap” which they previously had.

Those potentiometers on the controller are as they were from Inventables; I’ve yet to change those…

From a quick overview the belts are otherwise in undamaged shape (couldn’t find any missing teeth), and the NEMA setscrews are still in place. I’m going to re-tighten the Y axis belts first thing tomorrow and restart the calibration sequence.

In terms of cutting circular, circles… This is my current benchmark; I have high hopes for improvement with the successful calibration of both axis.

Thanks - Will update tomorrow.

1 Like

It was the Y Axis belting!

I re-tightened, and added zipties to both the dynamic and static sides, so the belting should stay put.

I repeated the calibration process (moving 500mm on both the X & Y axis). The X axis ended up at 39.499 steps/mm; while the Y axis seemed fine at 40.000 steps/mm.

The problem is I’m still not getting very “circular” circles. The below photo is of the same drawing repeated 3 times, you can see that the “oblongness” of the circle changed a bit between calibration’s… But I’m still pretty far from an actual circle.

For reference the circle is a fill cut, 10mm in diameter. Measuring the column on the right; the circle(s) are 10mm vertically, and 8.6 to 8.8mm horizontally.

The wheels secured by eccentric nuts on the X axis/gantry are all finger tight, and the X axis belt is secure, roughly the same tension as the Y belts… What else could be going on?

It looks like you’re not getting microsteps on your X-axis, something I’m currently working out on mine as well. It’ll move large distances, but .001" and sometimes .010" movements don’t always happen. To verify this, try moving .001" 50 times or so, and see if there is any change in position at all.

2 possible problems I’ve located are (a) belt tension is wrong, either too tight or too loose, or (b) potentiometer is too low:

To check the belt tension possibility, you can loosen the belt tension up a bit (1 flat increments, keep track of initial tension nut setting) and try to microstep. If that doesn’t chance anything, then try tightening it up (again, 1 flat increments).

To check the pot possibility, turn the dial your X pot clockwise about 15-30 degrees from its current setting, and try to microstep. Repeat once or twice more, but don’t go too far.

Another possibility I’m dreading is the idea of a stepper motor being weak or bad. I highly doubt it though, since it still works. There’s no guidance for tension, so right now it’s just a “make it up as you go” type thing.

So this machines ability to make a reasonably perfect circle, is honestly not a topic that Inventibles has covered/supports? This can’t be right…

1 Like

Inventables hasn’t released a “guide” to tension. I’m currently working on developing a method to measure it, but until I get it completed it’s just something you need to tweak as you go.

1 Like

Rethinking this…

If the Y axis is repeatably making accurate cuts to within <1%, and the X axis is repeatably making cuts that are off by ~14% each time; then I don’t see why this would not be an adjustment problem.

So back to the basics, I’ve repeated the pattern for loosening/tightening the eccentric bolts on the gantry, as well as loosened & retensioned the X axis belt clips.

This time I’ve added zipties to secure all of the beltsclips, X&Y axis.

It’s possible/probable that what began as a correctly positioned wheel/belt, worked itself loose with the operation of the machine. I also purchased a bottle of Loctite meant for bolts <6mm which is the color purple. Couldn’t find it locally, but Amazon did have it for sale here

Going to re-calibrate the steps/mm and see if the cutting accuracy improves this time.

I just wanted to mention that yes, the a well setup machine should make pretty accurate circles. I’ve found the main problems to be

  1. belt’s are loose
  2. v-wheels too loose (I make sure they aren’t easy to spin by hand, by adjusting the eccentric nut)
  3. missing steps due to not enough motor torque (potentiometer set too low)
  4. pulleys are loose on motor shaft

Personally, I’m usually getting squares to match within ~0.01in by checking for the above 4 items. Sounds like you have you have checked #1 and #2, so my guess would be #3.

What is your depth of cut, and have you tried decreasing it? Decreasing it will directly lower the forces on the motor, making it less likely to miss steps.