Stalling at top of Z axis, drive rod wobbling, trouble adjusting pots

Hi folks,

I’ve been struggling with this a few days now, searching the forums extensively and trying to troubleshoot on my own, but can’t seem to fix this problem.

The X-carve is going along just fine and then all of a sudden it starts to skip steps in the Z direction and gets itself stuck way up high to the point where it’s not cutting anymore. It seems to stall mainly at the very top, both when cutting and when I toggle it up and down with the computer. (I’ve also noticed that the drive rod wobbles a little as the spindle mount moves up and down, but don’t know if this is a related problem or separate.)

Other people who have had problems with skipped Z steps have been told to adjust the potentiometer. I went through the whole process but I can’t seem to find that sweet spot - there doesn’t seem to be a middle ground between too high and too low where it actually works. I go to where the voltage is too high and it trips, then keep turning it down bit by bit to try to find where it stops tripping. I keep thinking I’m there but keep moving it up and down to be sure, and it inevitably stalls out. I move it down again. It stalls out. Finally I reach the point where the voltage is too low, but at no point in between has the motor been happy.

I’ve also tried tightening and adjusting nuts here and there, some were loose but don’t seem to have made a difference.

I’m wondering if I’m doing something wrong adjusting the pots, or if there’s a problem with my wiring, or if something else is going on. I have a video of moving the spindle up and down, if that helps, but attaching it isn’t working for some reason.

Thanks for your help - hope my description makes sense and that I didn’t miss some simple fix already on the forums. Excited to finally get to work once I manage to get this thing running properly.


I would recommend adding a picture of your Z axis. I sent a pic to the Inventables team and they provided me some feedback on how my top screw was not tight enough. May not be your issue but may help others troubleshoot with you.

Stalling at the top is a known issue due to something being off. Maybe the holes in the top-plate are offset?

I think people have had success by adding thin washers between the threaded, nut-block and the carriage.

A little wobble towards the bottom of the rod nut should not be an issue.

I had to take a break from this so apologies for the late reply!

@JeremyHill Thanks for the suggestion. I’ve attached a few pictures.

@TonyNo Thank you for the advice. Can you explain a little more clearly what you mean by that? Which holes in the top-plate? I’m still pretty new to this.

I wasn’t the one who put the machine together initially, but as you can see some of the screws in the pulleys are not the proper inset screws; they still fit though.

Thanks again for your help.

Yeah the screws are fine, I just wanted to make sure nobody thought that was the problem. It’s nice to have something sticking out to grab on to. Although they were loc-tited, one of the pulleys got loose and I tried to tighten the screw and now it’s stuck spinning in place, can’t get it tight or remove it. But that’s a separate issue from the main one, I think.

These holes…