Step Over on larger bits?

I just ran a simple cut - rectangular “fill” to thin down a piece of wood. I used a .75" bit with reasonable cut settings in Easel. When it started cutting, it was painfully obvious that it wasn’t conforming to the standard 40% step over. I double checked that setting - it was 40%. The bit was taking less than 1/16" cuts on that 3/4" bit, so it took FOREVER.

Has anyone else experienced this with “larger” bits?

GA! Nevermind. It looks like I somehow selected MM for the bit size (.75mm). I ran a simulation after setting it to IN, and it looks much better. I should have stopped and investigated at the time. I cut a lot of air today. LOL

1 Like

When you put in .75 inches in Easel it automatically changes it to .75 mm. You have to change it back every time!

Annoying - and good to know. Thanks.

I did the same thing this week. I was flatting a cutting board i had made and thought this is going to take forever. Then noticed it switched to mm instead of inches. I thought i hit something to switch it but good to know for next time.