Stepper motor issues on X-carve

Working on setting up my X-carve. Testig X axis now and the motor does not work properly. It reacts but does not complete the movement it should.If I gently push the carriage in the direction while jogging it will complete the movement - if not it will kind of “wobble” but go nowhere.

Could it be microstepping settings? Is it 1/16 - could this be the issue? My CNC shield is currently set with 1/8.

Any other ideas?

Grateful for any help - thanks!


Make sure your eccentric nuts and v-wheels aren’t too tight

Thanks I will doublecheck, however it slides nicely when just pushing the carriage with my hands…

I have the same problem with my X-Carve. I tried to cut a project in Komatex and after cutting the first piece the motor seemed like stopping for a second and didn’t make the entire course.

I uploaded 2 photos as the project turned. In the second photo it can be seen how instead of going and cutting from point A to B, it jumped only till point X. I stopped the process and remade the second piece. When it’s about to go more than 40 cm, it just goes crazy and it cuts where he wants.
Does anyone have this problem or know how to solve it?

Sorry to hear you also are experiencing issues. Are you running your own CNC shield/arduino or bought through Inventables? Do you have heatsinks on the stepper drivers and proper fan to cool down? Has it worked properly before or been like this since the beginning?

Seems like X-axis is ok but the Y that is not performing well…can you confirm that?

Can someone btw confirm the microstepping settings just to get that out of the way: should it be 1/8 on all three axes??


I bought all the pieces from Inventables. My X-carve is 1000 mm x 1000 mm. This has been a problem from the beginning when i wanted to cut an apple of 44 cm long and with 1 square in the middle. After cutting the apple correctly, the square is cut in different parts of the apple, but never in the middle. I also tried with other projects but if the distance from where i fix the spindle to where it cuts is more than 20 cm, than blocks for a second and not going the whole distance on the Y axe.
I thought maybe the commands don’t go fully from the board to the motors or the V-wheels are too tighten but they seem to go good

Should be just one gcode command to go from A to B so for some reason your Y is losing steps. If you do not get any answers here in a decent amount of time I would have contacted and explained the issue.

I am using Easel, because i didn’t had time to fully learn and understand V Carve Pro…i hope this is the problem, so i am more calm


First for future reference : x and y are 8x microstepping, z i 2x microstepping.

Got everything working, it was a mixed issue. I had two wires that where connected which caused malfunction.

In addition I needed to fine tune current from the stepperdriver (a screw on the driver polulu a4988).

Voila everything works :slight_smile:

Hi Christian, I’m having a similar problem. X and Y motors are making short erratic, rapid lunges. Z is moving fine. Where is the screw that you adjusted the current? The machine was running fine for a while then this problem just appeared. Any more help would be appreciated. Thanks.

Hi Matt
What kind of stepper drivers do you have? I only know polulu but if you Google your drivers I’m sure you will find some more info?

Have you btw checked how tight the belts are? Too tight might also cause issues.


I haven’t used my X-Carve for a month and i tried to use it today and my spindle doesn’t start unless i twist the mill with my hand and also it doesn’t make the same noise as before. It looks like it lost power. I use Easel and i always have the spindle set on automatic at 14.000 RPM. Is it possible that the spindle has problems or what could the problem be?

Could this be the pulley slipping on the motor axle?

I don’t think so

If spindle starts with finger help, you better call help desk for replacement or other alternatives. It’s known issue.

Thank you for your response. I will do that

Yep - I got a replacement unit recently…spindle suddenly stopped working.

Here’s something to look at that’s so simple that nobody thinks of it. Today I ran a job, then turned the workpiece around to run again on the other half… Too long for my machine. Ran the same program with the same settings, same zeros, etc., and it went nowhere quick. Y axis was trying to move and couldn’t. It just sat there chattering at me. Went through everything, cleaned everything. Worked great for 5 seconds then did the same thing again. What was it?

One bad wire connection to the z-axis. Pulled that wire out, re-twisted it (remind me to tin those one of these days), stuck it back in and tightened it down, and job ran perfectly.

Did you get a solution to this? I am having the exact problem!

“Hi Christian, I’m having a similar problem. X and Y motors are making
short erratic, rapid lunges. Z is moving fine. Where is the screw that
you adjusted the current? The machine was running fine for a while
then this problem just appeared. Any more help would be appreciated.

@JamesO_boyle, what kind of setup do you have? Are you running with gShield or another cnc shield (with e.g. Polulu drivers)?

Anyways there is a small screw on all drivers which you can adjust. You can e.g. run some gcode producing a 10x10cm square (but with no spindle on and z in the air) with say 800mm/sec. Then carefully and slowly adjust the current on the drivers for X and z with a screwdriver until the motors are humming with a healthy sound. Google it - you will find many examples of this.

Of course first check for any mechanical obstacles and double check your wiring.

Best of luck, Christian