Stepper motors wont respond after z-probe malfunction

I got an x-carve for Christmas and completed installation/first project today. I noticed during the first project set-up the z-probe connection was shotty at best but was able to use it after testing numerous times (and holding the connection a certain way" before committing to “start probe” which is suicide if it doesn’t work because the only way I found to stop it is the big red button. For the first project it worked (I did have to hold the connection) and the rest of the project went off without a hitch. So I went to start the second project. I clamped down the material and went to do the Z-probe. I tested the connection by first plugging in the connector and spinning it numerous times before the program realized it was there then put the disc on the clip and removed until I felt like I had a good enough connection that it was fairly consistent and I could trust the “start probe” button. I pushed it but this time when it met the disc instead of retracting to a happy position like it did during my first project, it decided it wanted to drive the disc halfway to china with as much force as it could muster (it would be nice if easel would offer a “stop probe” button in case this decides to happen). Once I finally got the thing to stop I decided that I was done with the crappy z-probe and its connection issues until I could talk to inventables about it and I would just use the manual option for setting the z-axis. I backed up in my project on easel and chose the manual option but when I tried to move any axis, x,y, or z none would move. I have restarted CPU, x-controller, and searched the forum but have come up with nothing.

I do hear the motors receive power when I power up the x-controller and notice that when the machine gets power the motors will barely move (like they have power to them that is preventing rotation) if I try to move them with my hand (as opposed to when the machine is off they move fairly easily by hand)

The emergency stop button is fully pulled out (and twisted) so that is not the problem

The fan runs and lights come on when I turn on the x-controller

The wiring is correct as I successfully completed a project minutes before this happened with no issues.

I have tried to redo the setup from easel but it hangs up on the “writing configuration” screen

Easel is connecting to the x-carve (I know because the carve button in easel goes from grey to green when I power up the machine) but when I get to the “work zero” tab of the project set-up none of the “machine controls” will work in any axis or an any step interval.

I have shut everything down and rebooted. I have let everything run for a while but the “machine controls” will not work.

Has anyone else had this problem or anything similar? I am thinking the board must have died or something. I will call inventables Monday to hopefully resolve the issue but I just was going to check to see if there was some way to reset or other way I could fix the problem myself.


I had problems with the new z probe as well, seemed intermittent and was heading to China as well. I soldered on a smaller alligator clip that attaches directly to the router bit and soldered a heavy duty banana plug to fit much tighter into the puck. It works 100% of the time now.

Just a thought, the machine (controller) could be in an ‘alarm’ state and requires a homing cycle. (Easel should prompt you automatically)

Open machine and find the ‘Home’ button.

Thank you I did not realize there was a home button. I did find it and it worked to bring the machine to home (first time it had moved since its excavation to China… big sigh of relief) so now I have ruled out the motors or board being bad and my machine is back “home”. But I am still not able to move the machine in any axis with the toggle switches that are found in the carve button.

From what you told me I found the machine inspector button and I have this reoccurring error message. I have tried restarting both the machine and my computer and have tried to re-run the machine setup in easel but it hangs up in “writing configuration” forever without progressing.

Any ideas on where I should go next. I am searching the forum for this error message.

Your firmware is as current as mine…
What’s the usb cable like (length/quality)? Got a spare you can try?

You can also purchase Charley Thomas’s Triquetra zeroing touch plate. It does all 3 axis at the same time. Many folks here use it. Also, if you use a powered usb hub, you will be better off.

The USB connection is good like you said. The probe is not connected and I have restarted since disconnection. I guess I will call customer service. I will report back what I find. Thanks to all for the suggestions.

Any updates???

I called inventables and we reflashed the x controller and reran the setup and it worked like a charm. They didn’t really know what happened or why but tried some other things to fix it before the reflash but they didn’t work. They did send me another z probe and I haven’t had any issues with the new one.

1 Like

Link for the alternate touch plate?

NM, googled.