Steppers quitting mid job

I have a home brew CNC machine. Everything is wired and was running perfectly.

I changed to series wiring from a single controller to control both Y-axis steppers…and once dialed in everything works great.

However when I run a project the motors just stop all at once. Of course the job is ruined because the arduino does not know the motors stopped so any chance of rewinding is not a possibility.

I am using 4-Nema24s a 48v power supply and HC controllers. I have tried with easel and UGS. It stops at different times during the project. I have triple checked the wiring and everything is spot on. Nothing is hot, and nothing smells funny. Its like it pops a breaker, but the breaker is never tripped on that circuit.

I’m running 3.5 amps to each of the motors from the controllers, so it doesn’t seem like that should be an issue.

Once the motors shut down…if unplug then replug to the wall everything is fine immediately after the failure.

Any help would be greatly appreciated,

Sounds like EMI (Electromagnetic interference). Lots on the forum. Keep your USB away from any other wires. Does the same thing happen if you’re running an air cut without turning on the router?

If all steppers stop at once you are experiencing USB dropout. This can be due to EMI like Neil suggest or power management (PC) for your USB-port.

If you install homing switches you can restart at the same work zero since you have a known reference point (Machine zero @ homing switches) and your work zero is stored as an offset of machine zero.

Thanks for the info…in typical troubleshooting mode I made more than one change at a time. One or all may have fixed it.

First thing I did was to shield the usb cable with copper foil.

Second I jacked up the power on each controller.

Now the router and shop vac die but the motors haven’t stopped in a 2 hour air cut. Pisses me off that I broke the bit when the spindle stopped but easel kept sending code .

I have the spindle and vac running during the air cut.

Is it safe to run NEMA 23s at 4.5 amps?

Most likely not, most Nema23´s we typically use top out at 2.8A as max current.
But at 48V supply voltage there is plenty of power.

Update…the issue was a bad extension cable. I appreciate all the help you have given me.

Okay I will pull the amps back.

Since the two y axis motors are running off the same controller in series, what should I run their power at?

Didn’t work motors and Arduino kept working but vacuum and router tripped the power strip breaker…another bit ate it.

Is a 120v standard circuit enough to handle a router vacuum and cnc? I have the power supply trimpot set to full.

Router and vac on the same circuit will likely overload the breaker.