Steppers won't do anything after installing grbl 1.1f firmware upgrade

I’ve got an xcarve that has been kitted together. I bought it used with gshield v5 and an arduino uno. I’ve had it for about a month now and was looking into upgrading the nema 17s that it was equipped with to nema 23s. Well, I was testing the Z axis with the new 23 and it works great in the grbl controller program.

But in Easel, it would make like it wanted to turn, freeze, then continue to turn. This is with no load and would do it with the gshield trim pot set literally anywhere. (The old steppers were working fine).

So after that I noticed that Easel was asking me to upgrade to grbl 1.1f. I did. Now nothing is working in Easel, and grbl controller is saying “(CTRL-X) No data from COM port after connect. Expecting GRBL version string.”

I can’t control the steppers anymore. I have no idea what went wrong, or how I need to fix it. I tried getting the Arduino IDE and following the instructions to manually upload the grbl firmware, but there was no change. What can I do to fix it?

You need updated control software for GRBL 1.1.

If you didn’t update your Easel driver, you have to.
You need an updated version of GRBL controller as well.

I recommend making sure those work before continuing.

Also, your GRBL “$$” settings would have been reset to default. If you don’t know your old settings, I recommend running Easel machine setup again to set the values properly.

Thanks for the response. I have grbl controller 3.6.1. I also have tried to install Easel version 3.8, but I have no idea how to see if it is working. The download page shows 3.7 as current. I’ve redownloaded the driver twice and no change.

Otherwise no changes. I’m still not getting anything. Setting up the machine didn’t help.

Edit: Fiddling around with the controllers, I’m getting this at the 115200 baud setting:

Grbl 1.1f [’$’ for help]
[MSG:Check Limits]
[MSG:’$H’|’$X’ to unlock]
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|WCO:-3.8000,0.5000,-0.5400>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|Ov:100,100,100>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]<Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>

G91 G0 Y1
error:9
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|WCO:-3.8000,0.5000,-0.5400>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|Ov:100,100,100>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>

G91 G0 Y-1
error:9
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>

G91 G0 X1
error:9
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|WCO:-3.8000,0.5000,-0.5400>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ|Ov:100,100,100>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
[verbose]Alarm|MPos:0.0000,0.0000,0.0000|Bf:15,128|FS:0.0,0|Pn:PXYZ>
**** Connection closed ****

It posts these repeated positions and when I try to control the steppers, they throw an error?

The status report is showing that the probe pin and all of the homing switches are tripped.

Can you post the $$ output from grbl here?

I’m new at this sort of thing, so forgive me if this isn’t the whole thing, or if it’s not the right thing at all.

$$
$0=0
$1=0
$2=128
$3=63
$4=1
$5=1
$6=1
$10=3
$11=2147483.648
$12=2147483.648
$13=1
$20=1
$21=1
$22=1
$23=255
$24=2147483.648
$25=2147483.648
$26=255
$27=2147483.648
$30=1
$31=0
$32=1
$100=40.000
$101=40.000
$102=320.000
$110=0.000
$111=0.000
$112=-2147483.648
$120=0.000
$121=-58162.952
$122=0.000
$130=790.000
$131=790.000
$132=-0.000
ok

Edit: Looking at the grbl docs, these settings are all kinds of horribly messed up.

That’s your problem. They should be similar to this:
This is the default set with homing enabled.
$0=10
$1=255
$2=0
$3=3
$4=0
$5=0
$6=0
$10=1
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=25.000
$25=750.000
$26=250
$27=1.000
$30=1
$31=0
$32=0
$100=40.000
$101=40.000
$102=188.947
$110=8000.000
$111=8000.000
$112=500.000
$120=500.000
$121=500.000
$122=50.000
$130=790.000
$131=790.000
$132=100.000

Yeah, I’m seeing the documentation for the first time. This is weird. I wonder what happened that these settings got so messed up. Generally the settings should default after a firmware update, right?

Maybe yes, maybe no. Depends on which version you had previously and which one you load in place of it.

Thanks for the help. The steppers are now functioning. I have another question, though. So I’ve reset all the settings and I noticed that while grbl controller would run the z-axis perfectly, UGS and Easel would struggle, where it would spin-stall-spin. I fiddled with the max rate, lowering it down and now it’s functioning in UGS and Easel. Why would it work in grbl controller at a higher rate, but nowhere else?

Can’t think of any reason that would be happening. Are you testing using the same physical range and location of the Z axis in all programs?

Maybe there is a mechanical binding that occurs at one place on the Z axis, but not others.