Steps changing on own

Hello fellow x-carvers! I am using x-carve 1000 x 1000 with standard arduino and grbl running a makita wood router on variable speed set and turned on/off manually
I am fairly new to this fabulous machine but have built it all up and run various projects.
Most have turned out fine but a gremlin seems to have appeared - for no apparent reason the z axis steps appear to default to about 320 instead of approx 189. Result is that a 1mm deep carve suddenly starts at almost twice as deep and so it can ruin the job very quickly by biting in to hard and if not stopped can quickly cut beyond the set workpiece depth and into the sacrificial board. I always check material dimensions are 100% correct so know it’s not “pilot error”
I have worked out how to reset the steps to correct setting and will then work fine until a job or two later when th gremlins come out to play and thus the cycle starts again with reset and wait until it happens again.
Can anyone please offer any clues as to why and how to avoid.
Would be great if could check quickly steps per mm on each axis.
Will eagerly await any input from you guys as cant find anything in the general faq’s
Many thanks in advance.
Mik and Jayne


I would guess this might be an Easel issue if that is what Mike is using. It is suspicious that the 320 number is about the right value for the M8 screw and the 189 number is about right for the ACME rod.

1 Like

That’s right I am using easel.
Mystery is what is causing the grbl to change setting as there isn’t any warning it’s changed so first clue is when the carve starts it immediatly is obvious to an engineering ear that the cut doesn’t sound right so am on guard that unless it sounds right the gremlins have been playing tricks again.
As Larry indicates that the two rods have different settings I will keep an eye out for that as a possibility. Maybe I will have to ensure each time prior to starting via machine inspector that I check the acme rod is selected and not the rod.

Something is causing it to change. Grbl only changes something at the request of a user (like Easel). If it were a hardware failure you would most likely get garbage rather than a valid number, especially a number that matches the M8.

I don’t know how long he has had this problem.

I have had the issue for a few weeks so don’t think recent easel matter was the cause.
I m monitoring the matter now I know that it could have been caused Via the machine drop down box as I didn’t realise that the settings could change by chosing the rod instead of the acme for z axis.
Maybe a warning to other novices to be careful!!
Very grateful to you all for your input.
Collective expertise is brilliant.

1 Like

Many thanks for your valued guidance Phil. I am going to sit quietly and watch your tutorials. I am sure that there will be many out there that really do appreciate the guidnce by you and indeed other knowledgeable users so keep up the good work.
I thought I was doing well and have produced several great projects but now know that I still have much to learn - and love it!!
Keep up the good work.

1 Like