Inventables Community Forum

Still cannot connect easel

Ok, easel does not connect to my xyz carve (grbl 1.0g board)
stuck on the connecting to… screen
tried fresh install win 10
tried uninstall and reinstall all drivers and easel local
tried restarts and plugging and unplugging

tried an entirely different computer.
Can connect perfectly fine with UGS or such,

Reason i want easel to connect, my son likes making things and easel is easier for a complete novice to get used to before going for the uphill learning curve of proper CAD.
But alas. I cannot get it to connect, my comments here, on other groups ect remain unanswered.
I have no way to see what port easel local is looking at, on the laptop (lappy to run router alone) its com3, on my pc, com4.

Upgrade to 1.1f. Any reason for the 1.0? If I remember correctly, it was never an official version.

Anywhere I can look at how to update it?

Download the hex file on the page I linked to above and then read this:

updated grbl, made zero difference. I read on other posts people have same issue and downgrading to older easel local allows them to manually set com port… why dont they have that option currently? I am gonna have to try older drivers…

To which version?

Restart everything, unplug & re-plug USB, only open Easel. Still doesn’t connect?

By the way, you can design in Easel and still use UGS as a sender. Just export the gcode.

1.1f and tried the newest one too

figured out how to set port manually, but it still does not see the controller :frowning:

Nothing else (UGS, for example) is open? Computer restarted? USB unplugged and re-plugged?

Yes, and tried fresh install win on laptop, easel just will not connect, but can open ugs and connect no issue.
Like I said tried different comp, same thing, fresh restart, not running ugs, same issue

Tried a different browser?

Try just unplugging the USB from the pc, then replugging it. I have to do this often. Youll know if it works the machine will move and the software should continue.

When I first got my machine I could not connect my primary laptop. I could download the .exe file but for some reason it would never connect to the machine. After over 6 hours with tech support we were never able to come up with a resolution. I am running windows 10 and tried several different browsers to no avail.

I ended up having to utilize a back up system.

Tried chrome, Firefox, edge, and on a different computer too

Yes, tried, and different computer, different cable, different ports, no difference

Does not work on laptop or PC, on any browser, different usb cables, different ports, different com ports.

With such a broad failure scenario most fingers should point towards the controller itself.

But then the controller works perfectly fine for other programs without issue, no connection issues at all…

Tried reinstalling the driver?
Why not just use the other programs? Easel generated gcode can be sent with any GUI sender.

1 Like

That is strange, I dont have a solution for you myself but hope you figure it out.
Sounds like your particular controller really dont like Easel… :frowning:

Yes tried,
Reason I am wanting easel to connect is I want to show my young boy it, and get him using it, and transferring code, setting up on a more complicated system is a much steeper learning curve.