Still can't connect x-carve with Easel

I’m starting to get frustrated. At first, I couldn’t get my computer to recognize my x-carve. I reattached the G-shield to the arduino, which worked. Drivers are installed, computer recognizes the arduino, but I still can’t connect with easel! All three axis lights are on, as well as the arduino light, but I just get stuck at the screen on easel where it says connecting to X-carve… I’ve tried restarting my computer, opening a fresh browser, and turning on and off my machine, but nothing. Can anyone shed some light?

There is a version of Easel Local that tries to automatically detect which COM port your Arduino is attached to.

That version can cause connection problems. If your version of Easel Local is greater than 0.2.2 try loading version 0.2.2 to see if that fixes the problem.

Also, as a test, you could try to connect using the Serial Monitor in the Arduino IDE to see if you can connect that way.


A few quick questions to help troubleshoot:

  1. Do you have another sender like UGS or Chilipepr open? If so only 1 can connect at a time. You’d have to close the other ones to get Easel to connect

  2. Did you flash the blink program onto the arduino? If so that erased the GRBL hex file and you won’t be able to connect until you follow this process.

  3. Try rebooting your computer. Sometimes I have seen where the port stays open and the only way to close it is to reboot.

  4. If all that fails then you can install the earlier version 0.2.2 for Windows of the Easel Driver.

What version of Windows are you running?


I’ll try to download Easel from the link you sent me, and see if that works. I don’t have any other programs running when trying to connect, and I haven’t tried running any code through the arduino, so I doubt I’ve erased Grbl. I’m running Windows 7, which I’ve heard can be a nightmare with this. So far it is, but I’ve disabled my firewall to allow the x-carve to be recognized by my computer.

Just downloaded the older version of Easel local, restarted my computer, and when I went to Easel to set up machine, it prompted me to download the new version because it said I didn’t have any version. I uninstalled the old version, downloaded again, restarted my computer again, and same thing. I just uninstalled it, and am installing the new one again. It connected this time! But my x axis doesn’t want to move in the setup. Checked all wires for x axis and they are wired accordingly with no loose connections. What’s the deal now?

If it’s connecting but the X axis isn’t moving most likely it’s:

a. A loose connection. The most likely place there is a loose connection is at the gshield. It can look like everything is fine but inside the terminal block there is a wire that is intermittent. You can try wiggling the wire while driving the X a few inches to see if you can get any motion.

b. A bad stepper driver on the g-shield. Possible but not as likely as a.

c. The hex file on the arduino is corrupted and needs to be reflashed

Hi, the links don’t work. I am stuck in a similar situation. LaserWeb will connect to and control my xcarve but easel will not. I do not know how to resolve this. any help will be appreciated. I am using a Arduino & gshield setup.

Hi @JoshuaRamPrakashPill - If you’re having issues, please reach out to our Customer Success team directly (here’s the link to call or email them) and they can help you out!