Stock size and origin not correct from Fusion 360 into Easel

Im very new to this, so I apologize if this has been discussed, or if I’m missing something really simple.

I’m working on OS X, and generated a project in Rhino first. I made sure to move its origin point to be at the bottom left of the file.

I then brought the STP file into Fusion 360, and its origin was correct.

For some reason that I have yet to understand, I can not get my tollbooth to show up with the right relation to home, or 0,0,0. It is importing into Easel, and placing the toolpath centered over 0,0,0.

I’m sure my issue is in my export of g code from Fusion, but no matter what I change, it still imports into easel the same way. Also, and I am not sure if this is or isn’t connected, when I change the material dimensions in Easel, it doesn’t seem to be altering anything in the g-code import view… though Im not sure it is or isn’t supposed to - just something to note.

My toolpath Im showing is just simple 2d+, but its reacted the same to 3d carving toolpaths I’ve tried to import as well.

And lastly, I apologize if this has been mentioned somewhere, I did attempt to search the forum, but wasn’t finding info on this exact issue - beyond one thread I saw suggesting turning the clampOffset to 0, which I tried, and didn’t change the import.

Any help would be greatly appreciated!

1 Like

I may have figured it out - and again… could have just been a really elementary thing that I missed.

In the CAM section of Fusion, I changed my setup to be a fixed sized stock box, and moved it WCS origin to be at the bottom left/top point of the stock box.

BUT, if anyone has a lot of experience preparing toolpaths and g code for easel or the x carve from Fusion, I would be happy to hear any insight.

1 Like

@CaseyCrescenzo - without seeing the setup I can’t tell exactly what’s going on, but I always put my WCS origin at the lower left, top corner of my stock and set all offsets from (-). I also manually set the stock size to what I actually have rather than something based on the model. It took me a really long time to figure out how to set my coordinates and axises in fusion. I still have problems at times. But once you get it nailed, it will work perfectly.

I’ve never used Easel to cut - I just take the post-processed gcode into UGS and move along my way. I use the Shapeoko2 post processor (slightly modified) but I hear there is a grbl and another post processor too.

Hope this helps…


1 Like

I think that was exactly my issue. I had assumed the origin in my Fusion file would translate to an origin for the the origin in relation to my toolpath, but glazed over the ability to change the WCS in relation to the stock. Now that I’ve changed that to the top most point of the bottom left corner, it seems to be translating into Easel perfectly. Thank you for the insight!

This is exactly how its done, when you setup your stock, fixed/relative/etc, you have your work zero coordinates that you need to setup, the defaults are almost wrong every time. I always pick the top face for my Z and that’s it, your X or Y might be flipped, if that’s the case just tick the box and done! :smile:

I’m not sure there isn’t something else going on. I’m just getting started in CAM, but yesterday I did set up the WCS to the front/left/top of the stock of the Fusion 360 model, then used the Easel post processor, then when I imported it into Easel I could see in the preview that the origin had moved 30mm down and 20mm to the left - Z seemed fine.

So when I set up the carve in Easel I homed, then moved the tool to what I thought the work home should be, then moved down 30mm and left 20mm and then told Easel that was the home and got a good carve. But I don’t think I should have had to do that.

Hmm, must be an Easel bug, i use ugs and chillipepr and never had that problem.

@StevePrior - you should not have to do that. Not sure what is going on. I’d be interested if you installed UGS and see what that does. That will rule Fusion in or out. And Easel in or out.


I just checked in UGS with my original nc file and it had the same offset. Then I went back into Fusion and switched from the Inventables supplies f360-easel.cps to the generic grbl post processor, loaded that into UGS and the offset went away. Looks like the problem is in the Inventables post processor.

1 Like

I’m looking at a diff between the current grbl.cps and the Inventables version and ran across this bit that Inventables added:

function clampOffsetDistance() {
if (unit == MM) {
return properties.clampOffset * 25.4;
} else {
return properties.clampOffset;

and properties.clampOffset is defined to be 1.0. So it seems that clampOffset is always in inches even if the units are in mm. I see the clampOffset actually used elsewhere. I’d really like to know why this was done. Looks like undocumented magic to me - to quote Martha Stewart “not a good thing”.

If I change the clampoffset parameter to 0 the offset I found goes away.

@paulkaplan Can you clarify what the intent of the clampOffset parameter is (maybe it’s Carvey specific?) Some documentation would be good somewhere on this. And do I need to use the Easel post processor un Fusion 360 only when I’m planning to import the gcode into Easel, or should I be using it even with other senders like UGS?