Inventables Community Forum

Stopping Mid-Carve At Wits End

Hey there, I have been having this same issue after about the first month of use.

Here is what I have tried to date with no luck…

2 New circuits for X-Controller Only
Removing the Bulk Head Adapter
Replacement Motherboard from Inventables
Re-grounded my entire dust collection system from the vacuum boot by the router to the vacuum, and to a new 4’ deep earth grounded copper rod.
Battery Backup surge protector
3 different computers
Checked Brushes
Removed router cord from drag chain
Checked all connections
Ran in environment free of other power tools
LAN Connection to PC
Ferrite choke on USB
I will run 3 or 4 good carves then it will start having the stopping mid carve issue. I just ordered a powered USB hub to try.

I am extremely frustrated with this. I have sunk more time and money into this than I was led to believe that this was going to take to operate. I purchased this machine to give it a task and let it do its thing with out having to worry about babysitting it. Unfortunately, that has not been the case. It happens with random carves. Any more information would be helpful.

This machine was purchased October 2019

Calvin

I guess it could be a lot of things. Have you tried running it with the dust collector off and unhooked?

I have yes. Had the same issue.

Interesting. Does it go back to your zero postion when you send it back?

It has me either “Unlock” or “Rehome”

I usually rehome it.

I take that back. It only asks to unlock the motors. Not to rehome. I don’t lose power. Just like the usb disconnects briefly.

I have my CNC on its own Breaker, I am assuming that is white you mean by 2 circuits,

Might want to replace the wiring harness have you noticed if the issue repeats itself with the router in the same general X/Y position? when this happens

I had mine do this one time, but I was using my computer on line while the carve was running.

Yes, I have 2 separate breakers dedicated to the CNC. I haven’t noticed it being in the same area. I will watch to see the general location of where it stops. Thank you!

Have you tried running it with the ceiling/room lighting turned off?
Fluorescent lights can generate a lot of RF noise due to their switching nature, earlier I could kill my USB connection by simply turning them ON or OFF.

A long shot I know…!

I had lots of static related issues between the computer and the controller. Replaced the USB cable with the best quality I could find and that helped, but still had disconnection issues. The USB port on the outside of the x-controller connects to the motherboard via an ungrounded cable - and that was the cause of my problems. I connected the USB cable directly to the board USB port and all of the interruption/connection problems stopped.

For grounding, run a multi-point to ground wire from the frame of the x-carve to ground, and from the outside box of the x-controller to ground. Use a different ground lead for any of the dust extraction system. As the cart I have the x-carve on is 80/20, I also have a single ground wire from cart to ground (a wiper to the floor).

I use LED lights, nothing has changed as far as lighting since I first purchased the machine. I did run this machine with no issues for about 2 months steady. That’s what really throws me off on this whole thing!

I will ground the x-controller and the chassis when I have a chance and give that a shot! Thanks!

Anecdotal, but I’ve read here and on Reddit that poor USB cable quality can lead to a disconnect. You mentioned swapping out the computers, so unlikely it’s the USB driver on the computer.

Best of luck, I’m sorry you’re having this issue, hopefully it’s a simple fix considering the time spent.

Do Easel Machine Inspector display any status when it halts?
Can you post your GRBL values here for us to see?

is your screen saver and sleep settings on the computer turned off… I had same problem when I started the short carves were fine but if it went longer than my power savings settings then mid carve shut down…

A new well-shielded cable plugged directly in fixed my prior issues. Also a powered USB hub but I think it was the cable that really solved it.

Our AV guy at work is constantly being given broken equipment and says that 80% of the time he can “fix” it with a new cable.

Cable I ordered but I would think any heavier one where it’s more like $5 for a 3 foot cable versus $5 for 3 of them…

https://smile.amazon.com/gp/product/B00P0GI68M/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Hi,
I don’t think it’s a V-Carve problem. I think it is an Easel problem. I have a Vertigo CNC 600 x 600 mm made in New Zealand with a Makita router fitted to it. I started getting this problem about 3 months ago. Sometimes I just start to jog it and it stops part way along the X or Y axis, or a minute into a cut, so I click on the jog button, lift up the Y axis and recut with by clicking on button and away it goes. Other times I have shut down Easel and open it up again and select the last home button and it carries cutting. Hope this helps, I have been using Easel for 3 years now.

Cheers Raymond

Have you tried sending the gcode file using Universal Gcode Sender or some other software?

I fought this for a long time too. Even though I grounded from my dust shoe to my jet 1100vx dust collector it just wasn’t enough. I dropped a steel wire into the drum of my dust collector on a long shot to try to ground directly to the dust. I haven’t had an issue since.