Strange carve screw ups

I’m building a speaker cab and using x-carve and Easel to cut the holes for the speakers. This is nothing special and one would think it would be a piece of cake… But no.

Here’s what I am doing. 12" speakers requires an 11" hole. I prefer to rear mount the speakers so to give it a more custom polished look I have a recess for the speaker ring to fit into. I have it setup as a 2 stage carve. First, it cuts the recess at 12.260" at .0625" deep. The second carve is just the 11" hole. This is where all hell is breaking loose.

It will start the circle get maybe 30% done, give or take, and the suddenly shoot right and start to carve into the center of the wood. When I hit stop it doesn’t return the home position, it’s way off, by 6 or 8 inches.

The first attempt, it seemed ok, but failed to carve all the way through the 1/2" plywood, I have the depth set at .51" which should be too deep for .50 plywood. I did adjust the carve settings as I thought the time to carve was excessive for a couple of circles, but after 2 failed carves I returned the settings back to the original recommended settings. Same issue occurred.

I checked the easel project files to see if there are any rogue carve paths and nothing, just simple circles.

I did close the browser and restart the computer and xcarve to see if that would help but it didn’t. The only other thing I can think of is the last firmware update. After updating it was a real pain getting the machine set up right again.

Any clues to what the problem could be?

I have the Arduino. I checked everything else a couple of days ago. I’ll do it again to make sure.

Arduino gShield calibrated?
Spindle/end mill true perpendicular to the waste board?
Chips being cleared properly?

If carve go off track when it is deep the above issues may often be the case.

This machine has been lightly used and has been in great shape. I used it to create pretty detailed projects without any issues. These circles though seem to give it fits. I did make another one a few weeks ago that was ok, but was a single stage 11" circle only, but that one failed to cut all the way through, too. I used scrap plywood to test as I always do.

I tried this one several times. As you can see it suddenly shot off toward the center each time.

Same issues with this one. It seems to run ok until the second stage.

Based on the pix the problem is very obvious.
Unless the pix are sidelways. I used to face that problem when using belts. It’s the Hp of the spindle overpowering the stepper to pulley to belt holding power and walking off path. It will also explain the home being off by a few inches. Slipping belts. Check your pots and belts specifically on the x as it’s always the weak point. If you would like a permanent solution pm me.

Everything seems to be tight, Could it possibly be the custom settings I was using caused it to go nuts? I’m going to give it another go with slower carve settings and see how that goes. From the Easel project file, it appears that machine wasn’t seeing the settings change yesterday, or the changes didn’t save in Easel.

Ok, tried it again and everything on the first stage went fine until a breaker tripped… Had to start over the first stage finished perfectly. Second stage not so much.

I may have misspoken when I mentioned it doesn’t return home. If I home the machine before the project it homes perfectly. When the project finishes it returns to the home position perfectly. Only when it goes nuts it loses it way.

The second stage is simply cutting the 11" hole. I tried 2 times with the machine perfectly in the home position and both times cut was slightly off. Enough to ruin it, though.

It doesn’t appear to be anything loose. Nothing obstructing the path, it just the second stage carve.

Double check your pulley and belt tension.

I don’t have a fix, but have had the same issue with Easel and with Universal G Code Sender. My thoughts are that it’s more likely a controller issue. Sometimes the code just gets ignored (or missed). I’m running an older Windows 7 computer for UGC, and an engineering laptop for Easel. What’s your pc set up?

It’s either the pulley or the spindle causing the issues. Can u post ur grbl output?

I think I got it all sorted… Kind of.

I’m not sure if maybe something in the easel file was corrupt or not. So I just made a new one with a shallower recess. What happened on the first attempt was the router plunged and started cutting twice as deep as the cut. So, I stopped it. This time when I started the carve again a message appeared saying there was a freaking firmware update! I updated it and it seemed to run fine.

However, it still failed to cut all the way through the 1/2" plywood. there’s still approx. an 1/8" left to cut. I have the thickness set correctly in Easel. Are you supposed to set it deeper than it actually is for it to cut all the way through?

To answer some questions and hopefully get this sorted. I have the Dewalt router. When I bought the machine I went for the best available components at the time.

The computer I use is one I custom built. i7, 16gigs RAM, SSD’s, Win10… That’s what I create projects with. The one I execute the carves from is an older laptop and with all honesty is probably barely enough to get it done. It has Win10 on it as well. Never any issues until now though.

Grbl output… How do I do that? I would be glad to, but the only thing I have used is Easel.

The pulley… I have twisted every one of them to try and find one slipping, but they all seem nice and snug. The belts seem fine as well.

The main issues appear to have been corrected with that firmware update. Why It didn’t show before is another question. I definitely would have updated sooner.

Have you checked how tight the pulley set screws are? The torque on the pulleys when it is running in a deep cut will be greater than you can apply just by twisting. If your shafts have flats on them for the screws to bear against, make sure that they are. If there are none, take a file and make some. You might consider swapping set screws to cap screws, which will allow you to tighten them more (larger allen wrench). Reassemble with blue loctite.

If the machine was cutting counter clockwise around the circle, it was grabbing and the router was overpowering the motors or causing pulleys or belts to slip.

For the depth of cut issue, if you have checked the actual dimension of the wood and you are telling the machine to cut deeper than that and it isn’t, check the z pulleys, and if they are all set, calibrate the z axis steps per mm.

If the Z zero is at material surface, the Z is calibrated for distance and the gcode actually say go 1/2" you should go through 1/2" material.

If it do not, despite good input you have either a flexible Z (in height), a weak connection between pulley/motor/belts or a dull bit that is struggling to get down.

1 Like

I am going to overhaul this machine and make certain the pulleys are all tight. I probably need a new bit. It’s pretty black after the fubars and likely no good now.

RobertCanning, just one beer last night? :sunglasses:

1 Like

Overhauled… I found one pulley screw to be completely missing but doesn’t seem to be an issue. Will replace anyway. The rest were nice and tight. The Z mount was very loose, fixed that. I tried the carve again and this time it appeared to cut properly, but not all the way through in some places… The scrap plywood is warped and bowed, so I think that’s very likely the cause.

I did notice the Z is not square to the wasteboard. I watched the video on setting it up and from the side it is perfectly square, but the from the front it there is a gap like it needs to fall forward slightly. I see no way to make that happen and no mention of that in any of the setup videos or instructions. Is that normal?

best way to adjust is to slightly rotate the x axis rail

1 Like

you can also shim with thin metal, pop can aluminum works good.

Unnecessary step. Just loosen the the x on both sides slightly and move the carriage over to one side, square then tighten. Move carriage over to the other side and do the same.

1 Like

That’s a great tip! I just needed a little more adjustment.

1 Like