Stutters (pauses) when cutting text curves (Solved)

Brand new unit… not sure if it is easel or the x controller… I’m leaning to easel because it runs in a browser (completely dumb btw)… anyway, the issue… when cutting a curve or a circle… the bit moves about .250" tne sops, then another .25" then stops… etc, etc… leaving a jagged cut… anytime you stop a cutting process mid cut you get errors in the cut. I was attempting to cut a simple text thing in mdf… was cutting letter O first one was start stop start stop start stop and looks like crap… before it started the second O I hit pause on the x controller and waited about a minute… the second O was completely smooth and the bit did not stop once. The next letter with a curve ws back to the same ol same ol… straight line letter like I or K cut just fine. running easel on a high end gaming laptop with 32gb ram… x controller plugged into usb 3.0 port.

Can you post a picture or two of what’s happening? And it would also be helpful if you shared your Easel project so we can see that.

Did you create the project in Easel, or import it? What are your cut settings (depth per pass, feed rate)? What size bit? Do straight cuts work fine in both directions (left-right and forward-backward)?

will post picture later, but x-y cuts are smooth and even with no stopping… even diagonals are fine in both directions… it seems like it is stopping to calculate the curve or something… Project created in easel simple text… “COOK BONDING” (my company) bit size is .125" carbide end mill… Tried cutting in Acrylic (plexiglass) and the bit stoppage just caused the plastic to melt because it sat in one place too long. Feed rates and depth are those recommended in easel “software”… Even the first sample project the machine cuts was wonky… stopping mid curve, but cutting straight lines just fine.

I’m really curious to see your XCarve in action, if that’s possible for you. A short video of the XCarve carving straight lines in both axes, diagonal lines in both directions, and a circle, just so we can see what’s happening…? Something simple like this: http://easel.inventables.com/projects/5LT7S16KcXWbkoLziepVgA Or even your own project that you’re trying to carve. (Too share that project so we can see it and maybe spot issues, go to File > Share, select Shared With Link, then Save, and paste the link here.)

If you don’t have the bandwidth to upload video, I’d still like to see photos of the results. I’m just really curious about what’s happening real-time during your carve because mine has never behaved the way you’re describing, and I’m trying to figure out what might be causing it.

As you can see… the Letter C has multiple stops in the tool path… the O following the C was when I paused the x-controller for a minute before continuing… I allowed it to continue on to the next O where the tool path stopped several times… The O in the bottom word really shows the tool stoppage during the curve. The David is from the initial demo carve… Material is formica on particle board. Will try again today and post a video of what it is doing

The letter D also shows fine vertical lines but multiple tool stops during the curve

What else is the computer doing? Sounds like a sluggish serial communication issue. Have you restarted the PC?

Well, were that the case, wouldn’t it be stopping mid cut on straight cuts as well? but will give it a shot.

Ok… While I am awaiting the videos to upload to my computer from my phone… here are the results… Cut your test with no issues… ok, so decided to add some text above it and then deleted the original test… tun cutter… first letter cut fine…C second Letter O back to the same old stop and go… Ok,… Reboot… Try to recut Text “COOK” Problems right away on the first letter… and continued on with second… Ok… go back reload your test… Runs fine no issues. so apparently the issue is within the text generation itself in easel and not x controller. Still frustrating to say the least

Ok this is the First time cutting the C… Fairly smooth
https://discuss-assets.s3.amazonaws.com/original/3X/8/e/8e3d6dbdbbfbf253095a68aae77b724146d47183.MOV

this is the first time cutting the O starts out nice… and then…
https://discuss-assets.s3.amazonaws.com/original/3X/f/e/fe833d1de4180adea85b74542ae59167e484ae2a.MOV

this is the second time (going over first) (after a reboot) cutting the C Stutters like in the O… Think a Serious issue with Easel. after doing this, I went back and did your test cut… worked fine, no issues.
https://discuss-assets.s3.amazonaws.com/original/3X/3/9/395a63dee298e080688cac2cf721dea797f34a98.MOV

No.
Straight cuts are one command, “go to this point”. Curves are composed of a lot of extremely small straight shots.

have you tried in a different font?

Tried different fonts… same result… chatted with tech support… decreased router speed to 1… no difference… bypassed front port usb with cable directly to board… same result… updated firmware… same result

Tried a different GUI to send the code?
I like CNCjs.

can you run the command $$ and see what the setting are for 12=??? this is arc tolerance.

if you need reference you can read https://www.princeton.edu/ssp/joseph-henry-project/carvey/Write-up-with-guide.pdf which seems to be a very easy to understand write up on GRBL settings.

also do you have any spindle speed commands in your G-code?

this would make the axis stop movement while the spindle sets the correct speed.

I thought about that too, Kenneth, but that wouldn’t cause the machine to pause. And, for the most part, I can’t imagine why someone would need to change that value (mistakes happen, though.

He’s generating the gcode in easel.

@DavidMCook Does the same thing happen on an “air cut”, router off, above the work.

Well, I’m just using out of the box stuff in easel for lettering… nothing fancy…

.I recieved the machine on Friday, and finished the build on Sunday afternoon… 12hrs to build…

simple shapes like just a circle cut fine… it’s only letters that the machine gets wonky…

Confirmed yesterday, Air cut is exactly the same performance. and seems like the longer it “cuts” it gets worse, and then better, and the worse again…

Today’s experiment will be trying easel in other browsers… I really think that is where the problem is… that the application is browser based instead of stand alone. There entirely too many variables from browser to browser (plugins etc) that could effect application performance… I have noticed that with each new project I try to create, the functionality of the application gets worse, eventually requiring a restart of the browser.