Sudden probe issue

Since attempting to set soft limits for my 1000mm X Carve, I’ve found the probing function has stopped working. It recognises the lead is plugged in, and reacts appropriately when I touch the probe to the collet, but when I commence probing, the probing window opens, but no probing happens. I have attached a pic of my machine setting below… have I accidentally changed a setting?

The issue is likely related to the max Z travel setting in GRBL. When you start the probing the command that’s sent probes to a maximum distance. GRBL will throw an alarm if that max distance would be outside of the max travel setting for Z even if the probe would have stopped it well before it hit that limit.

The easy way to check is to try probing a thicker test piece of material. Assuming that works you can then tweak your $132 value higher until probing works with the size material you need.

1 Like

I hear what you’re saying. The problem is unfortunately that the probe won’t move at all. I have positioned the probe 1mm under the spindle, but the z axis has just stopped moving altogether when it’s time to probe.

Before I try to probe though, I can happily jog the Z axis wherever I like (as long as it’s within my soft limit, which is enabled to stop the spindle sliding off the bottom of the rail- I’ve upgraded and have extra Z height).

I had the same problem with probing after enabling Soft Limits. Inventables support could not find the answer but after a couple of weeks of frustration and playing with the problem I was able to find the answer.

You need to understand something about soft limits and how it operates. Soft limits are a proactive function. I like to think of soft limits as a “Mother May I?” operation. When the spindle moves about
the X, Y or Z axis by jogging, probing, or carving, soft limits does not stop the machine WHEN the spindle carriage reaches an X, Y or Z soft limit but instead before any X,Y,Z move is performed, the move travel Gcode command is calculated and if the move is calculated to be outside the soft limit setting of X,Y,Z the move is NOT performed and a Soft Limit Error is generated. This ‘Mother May I’ approach is what is going on with the Z Probe function. This is why the Z axis is not moved downward and a soft limit error prevents any movement.
Easel probe setting is set by default to a probing distance of 3.1 inches downward and will only stop when it touches the probe plate. The soft limit will not allow probing to operate because the 3.1 inch distance is usually outside the Z Soft limit.
In your GRBL setting you set the Z limit to $132=76.999 (Z max travel, mm). I have approximate the same Z Max travel value so the bit won’t go thru the wasteboard.

So to fix your issue you will need to change your Machine Settings for the Z-Probe Touch Plate. Here are my setting for my Touch Plate.

  1. In Easel go to ‘Machine’, ‘Setup Your Machine’ button and go through the setup process until you get to ‘Setting up your Z-Probe’ page.

  2. Click on Advanced Setting to change the Probe settings button.

  3. The setting that needs changing is ‘Maximum Probe Distance’. I find 0.5 inch to be a good distance. This change will allow the Z axis to move down 0.5 inches before stopping. You should place your bit a max of 0.5 inches above you probe plate. If you are over 0.5 inches you can just try probing again until it hits the plate.

  4. Now complete the machine setup and try testing the probe again with the Z.

Good luck.


Super comprehensive answer, thank you very much! I’m looking forward to it being daylight here so I can get out to the workshop and test this out.

Ken, after I enter my machine details in the first page, it takes me to the ‘test wiring’ page. None of the axis buttons do anything. I suspect somehow I’m triggering soft limits again? Should I turn soft limits off first? When I home the machine and try jogging each axis before going to machine settings, they all work fine.

Disabling soft limits for debugging sounds like a good idea.

1 Like

Just thought I’d check first, in case I broke another link in the chain :slight_smile:

I followed the advice in this thread, and the problem has resolved, for anyone else who searches for this issue in future. Thank you to @HaldorLonningdal and @KenFritz1 for their assistance.

1 Like